Plugins · storegrowth-sales-booster · data as of 2026-11-04
Is StoreGrowth safe? Known vulnerabilities and latest version
- Latest version
- 3.0.0
- Last updated
- 2026-11-04
- Active installs
- 2,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Sales booster for WooCommerce with BOGO, upsells, order bumps, direct checkout, quick view and side cart. Lift AOV without extra plugins. — by weDevs
What to do
- Update to the latest version (3.0.0). Anything older than 2.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get storegrowth-sales-booster --field=version shows what you run; wp plugin update storegrowth-sales-booster updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-39750 · published 2026-10-06
Cross-site scripting (XSS) in StoreGrowth (2.0.6 and older)
- Affected
- 2.0.6 and older
- Fixed in
- 2.1.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in StoreGrowth: Smart Sales Booster for WooCommerce | BOGO, Upsells, Direct Checkout, Quick View, Side Cart <= 2.0.6 versions.
high 7.5 CVE-2026-66466 · published 2026-08-13
Missing authorization check in StoreGrowth (2.1.1 and older)
- Affected
- 2.1.1 and older
- Fixed in
- 2.1.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in StoreGrowth: Smart Sales Booster for WooCommerce | BOGO, Upsells, Direct Checkout, Quick View, Side Cart <= 2.1.1 versions.
medium 5.3 CVE-2026-13110 · published 2026-07-28
Missing authorization check in StoreGrowth (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- 2.1.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Storegrowth Sales Booster plugin for WordPress is vulnerable to Missing Authorization in versions up to and including 2.1.0. This is due to a missing capability check on the bogo_category_msg_create() AJAX handler, which is registered for both authenticated (wp_ajax_) and unauthenticated (wp_ajax_nopriv_) users and only validates a nonce ('ajd_protected') that is emitted publicly via wp_localize_script() on every frontend page through front_scripts() . This makes it possible for unauthenticated attackers to modify the plugin's BOGO category-message configuration stored in the spsg_bogo_general_settings option by reading the nonce from any public page and POSTing attacker-controlled data to admin-ajax.
NVD CVE-2026-13110Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2026-13440 · published 2026-07-28
Stored cross-site scripting (XSS) in StoreGrowth (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- 2.1.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The StoreGrowth: Smart Sales Booster for WooCommerce | BOGO, Upsells, Direct Checkout, Quick View, Side Cart plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'message_popup' parameter in all versions up to, and including, 2.1.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit is possible because the 'ajd_protected' nonce required by the create_popup handler is exposed to all unauthenticated frontend visitors via wp_localize_script under bogo_save_url.ajd_nonce, effectively bypassing the nonce-only access control.
NVD CVE-2026-13440Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-15411 · published 2026-07-28
Missing authorization check in StoreGrowth (2.1.0 and older)
- Affected
- 2.1.0 and older
- Fixed in
- 2.1.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The StoreGrowth: Smart Sales Booster for WooCommerce | BOGO, Upsells, Direct Checkout, Quick View, Side Cart plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.1.0. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to overwrite the spsg_popup_products option with arbitrary attacker-controlled data. The 'ajd_protected' nonce used as the sole gate is exposed to unauthenticated visitors on every frontend page through the BoGo module's wp_localize_script call, rendering it ineffective as an authorization barrier.
NVD CVE-2026-15411Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-11-04 — latest release on wordpress.org (3.0.0).
- 2026-10-06 — Cross-site scripting (XSS) disclosed (CVE-2026-39750), fixed in 2.1.1.
- 2026-08-13 — Missing authorization check disclosed (CVE-2026-66466), fixed in 2.1.2.
- 2026-07-28 — Missing authorization check disclosed (CVE-2026-13110), fixed in 2.1.1.
Get an email when StoreGrowth has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for StoreGrowth (storegrowth-sales-booster) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by weDevs (7 tracked)
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/storegrowth-sales-booster (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/storegrowth-sales-booster"><img src="https://laskyr.com/plugins/storegrowth-sales-booster/badge.svg" alt="StoreGrowth vulnerability status"></a>