Skip to content
Laskyr

Plugins · storeengine · data as of 2026-11-04

Is StoreEngine safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6.0)

As of 2026-11-04. 3 issues are on record for older versions; version 2.2.0 or newer fixes all of them that state a fix.

Latest version
2.6.0
Last updated
2026-10-22
Active installs
700+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Sell digital & physical products with StoreEngine—a lightweight eCommerce solution with memberships, subscriptions, affiliates, coupons & licensing. — by Kodezen LLC

What to do

  1. Update to the latest version (2.6.0). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get storeengine --field=version shows what you run; wp plugin update storeengine updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-15056 · published 2026-08-16

Path traversal / file read in StoreEngine (2.1.1 and older)

Affected
2.1.1 and older
Fixed in
2.2.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The StoreEngine — Complete eCommerce Solution with Memberships, Licensing, Affiliates & More plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.1.1 via the parse_file_path function. This makes it possible for authenticated attackers, with vendor-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.

NVD CVE-2026-15056Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-9215 · published 2025-09-17

Path traversal / file read in StoreEngine (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
1.9.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The StoreEngine – Powerful WordPress eCommerce Plugin for Payments, Memberships, Affiliates, Sales & More plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.5.0 via the file_download() function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.

NVD CVE-2025-9215Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source

high 8.8 CVE-2025-9216 · published 2025-09-17

Arbitrary file upload in StoreEngine (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
1.9.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The StoreEngine – Powerful WordPress eCommerce Plugin for Payments, Memberships, Affiliates, Sales & More plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the import() function in all versions up to, and including, 1.5.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.

NVD CVE-2025-9216Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
StoreEngine vulnerability status badge
<a href="https://laskyr.com/plugins/storeengine"><img src="https://laskyr.com/plugins/storeengine/badge.svg" alt="StoreEngine vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit