Skip to content
Laskyr

Plugins · stops-core-theme-and-plugin-updates · data as of 2026-11-01

Is Easy Updates Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (9.0.22)

As of 2026-11-01. 2 issues are on record for older versions; version 9.0.21 or newer fixes all of them that state a fix.

Latest version
9.0.22
Last updated
2026-08-31
Active installs
300,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Manage all your WordPress updates, including individual updates, automatic updates, logs, and loads more. This also works very well with WordPress Mul … — by David Anderson / Team Updraft

What to do

  1. Update to the latest version (9.0.22). Anything older than 9.0.21 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get stops-core-theme-and-plugin-updates --field=version shows what you run; wp plugin update stops-core-theme-and-plugin-updates updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-7660 · published 2026-05-28

Reflected cross-site scripting (XSS) in Easy Updates Manager (9.0.20 and older)

Affected
9.0.20 and older
Fixed in
9.0.21 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Updates Manager plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'paged' parameter in versions up to, and including, 9.0.20 This is due to insufficient input sanitization and output escaping in the pagination() function. This makes it possible for attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page granted they can trick an administrator into performing an action such as clicking on a link.

NVD CVE-2026-7660Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2019-15650 · published 2019-08-27

Security issue in Easy Updates Manager (older than 8.0.5)

Affected
older than 8.0.5
Fixed in
8.0.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by NVD
Details from the advisory

The stops-core-theme-and-plugin-updates plugin before 8.0.5 for WordPress has insufficient restrictions on option changes (such as disabling unattended theme updates) because of a nonce check error.

NVD CVE-2019-15650wordpress.orgwpvulndb.com

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Updates Manager vulnerability status badge
<a href="https://laskyr.com/plugins/stops-core-theme-and-plugin-updates"><img src="https://laskyr.com/plugins/stops-core-theme-and-plugin-updates/badge.svg" alt="Easy Updates Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit