Skip to content
Laskyr

Plugins · stop-spammer-registrations-plugin · data as of 2026-11-04

Is Stop Spammers Classic safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2026.6)

As of 2026-11-04. 4 issues are on record for older versions; version 2026.4 or newer fixes all of them that state a fix.

Latest version
2026.6
Last updated
2026-07-18
Active installs
20,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.0+

A simplified, restored, and preserved version of the original Stop Spammers plugin. — by Web Guy

What to do

  1. Update to the latest version (2026.6). Anything older than 2026.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get stop-spammer-registrations-plugin --field=version shows what you run; wp plugin update stop-spammer-registrations-plugin updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-48876 · published 2026-06-15

Cross-site scripting (XSS) in Stop Spammers Classic (2026.3 and older)

Affected
2026.3 and older
Fixed in
2026.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Stop Spammers <= 2026.3 versions.

NVD CVE-2026-48876Patchstack advisory

medium 4.3 CVE-2025-14795 · published 2026-01-28

Cross-site request forgery (CSRF) in Stop Spammers Classic (2026.1 and older)

Affected
2026.1 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1. This is due to missing nonce validation in the ss_addtoallowlist class. This makes it possible for unauthenticated attackers to add arbitrary email addresses to the spam allowlist via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The vulnerability was partially patched in version 2026.1.

NVD CVE-2025-14795Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2025-2935 · published 2025-06-06

Cross-site request forgery (CSRF) in Stop Spammers Classic (2024.7 and older)

Affected
2024.7 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Anti-Spam: Spam Protection | Block Spam Users, Comments, Forms plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2024.7. This is due to missing or incorrect nonce validation in the 'ss_option_maint.php' and 'ss_user_filter_list' files. This makes it possible for unauthenticated attackers to delete pending comments, and re-enable a previously blocked user via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-2935Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2023-7065 · published 2024-05-04

Cross-site request forgery (CSRF) in Stop Spammers Classic (2024.4 and older)

Affected
2024.4 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Stop Spammers Security | Block Spam Users, Comments, Forms plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2024.4. This is due to missing or incorrect nonce validation on the sfs_process AJAX action. This makes it possible for unauthenticated attackers to add arbitrary IPs to the plugin's allowlist and blocklist via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2023-7065Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Stop Spammers Classic vulnerability status badge
<a href="https://laskyr.com/plugins/stop-spammer-registrations-plugin"><img src="https://laskyr.com/plugins/stop-spammer-registrations-plugin/badge.svg" alt="Stop Spammers Classic vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit