Skip to content
Laskyr

Plugins · stock-ticker · data as of 2026-11-04

Is Stock Ticker safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.26.2)

As of 2026-11-04. 6 issues are on record for older versions; version 3.26.2 or newer fixes all of them that state a fix.

Latest version
3.26.2
Last updated
2026-03-04
Active installs
2,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.3+

Easy add customizable moving or static ticker tapes with stock information for custom stock symbols. — by Aleksandar Urošević

What to do

  1. Update to the latest version (3.26.2). Anything older than 3.26.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get stock-ticker --field=version shows what you run; wp plugin update stock-ticker updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.8 CVE-2026-2722 · published 2026-03-07

Stored cross-site scripting (XSS) in Stock Ticker (3.26.1 and older)

Affected
3.26.1 and older
Fixed in
3.26.2 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Stock Ticker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.26.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-2722Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2023-27626 · published 2024-12-09

Missing authorization check in Stock Ticker (3.23.0 and older)

Affected
3.23.0 and older
Fixed in
3.23.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Aleksandar Urošević Stock Ticker allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Stock Ticker: from n/a through 3.23.0.

NVD CVE-2023-27626Patchstack advisory

medium 5.4 CVE-2024-6363 · published 2024-06-29

Stored cross-site scripting (XSS) in Stock Ticker (3.24.4 and older)

Affected
3.24.4 and older
Fixed in
3.24.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Stock Ticker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's stock_ticker shortcode in all versions up to, and including, 3.24.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-6363Wordfence advisorywordpress.orgPlugin source

medium 5.4 CVE-2023-51541 · published 2023-12-29

Stored cross-site scripting (XSS) in Stock Ticker (3.23.4 and older)

Affected
3.23.4 and older
Fixed in
3.23.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aleksandar Urošević Stock Ticker allows Stored XSS.This issue affects Stock Ticker: from n/a through 3.23.4.

NVD CVE-2023-51541Patchstack advisory

medium 6.1 CVE-2022-45365 · published 2023-12-14

Reflected cross-site scripting (XSS) in Stock Ticker (3.23.2 and older)

Affected
3.23.2 and older
Fixed in
3.23.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aleksandar Urošević Stock Ticker allows Reflected XSS.This issue affects Stock Ticker: from n/a through 3.23.2.

NVD CVE-2022-45365Patchstack advisory

medium 6.1 CVE-2023-40208 · published 2023-09-04

Reflected cross-site scripting (XSS) in Stock Ticker (3.23.3 and older)

Affected
3.23.3 and older
Fixed in
3.23.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Aleksandar Urošević Stock Ticker plugin <= 3.23.3 versions.

NVD CVE-2023-40208Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Stock Ticker vulnerability status badge
<a href="https://laskyr.com/plugins/stock-ticker"><img src="https://laskyr.com/plugins/stock-ticker/badge.svg" alt="Stock Ticker vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit