Skip to content
Laskyr

Plugins · stock-sync-with-google-sheet-for-woocommerce · data as of 2026-11-04

Is FlexStock safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.18.0)

As of 2026-11-04. 2 issues are on record for older versions; version 3.17.3 or newer fixes all of them that state a fix.

Latest version
3.18.0
Last updated
2026-10-29
Active installs
600+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

WooCommerce inventory and stock management plugin with real-time Google Sheets sync. Track, manage, and bulk edit products instantly. — by WPPOOL

What to do

  1. Update to the latest version (3.18.0). Anything older than 3.17.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get stock-sync-with-google-sheet-for-woocommerce --field=version shows what you run; wp plugin update stock-sync-with-google-sheet-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-107711 · published 2026-10-31

Stored cross-site scripting (XSS) in FlexStock (3.17.2 and older)

Affected
3.17.2 and older
Fixed in
3.17.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The FlexStock – Product Stock Sync with Google Sheets for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'products[].post_content' parameter in all versions up to, and including, 3.17.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable by any Subscriber-level user because the plugin's admin_enqueue_scripts callback exposes the REST bearer token in the Dashboard page source via wp_localize_script() without a capability check, and the REST endpoint's permission_callback validates only that bearer token rather than performing a current_user_can() capability check.

NVD CVE-2026-107711Wordfence advisoryCode change (fix)Plugin source

high 7.6 CVE-2025-30765 · published 2025-03-27

SQL injection in FlexStock (3.13.1 and older)

Affected
3.13.1 and older
Fixed in
3.13.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WPPOOL FlexStock stock-sync-with-google-sheet-for-woocommerce allows Blind SQL Injection.This issue affects FlexStock: from n/a through <= 3.13.1.

NVD CVE-2025-30765Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
FlexStock vulnerability status badge
<a href="https://laskyr.com/plugins/stock-sync-with-google-sheet-for-woocommerce"><img src="https://laskyr.com/plugins/stock-sync-with-google-sheet-for-woocommerce/badge.svg" alt="FlexStock vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit