Skip to content
Laskyr

Plugins · stock-locations-for-woocommerce · data as of 2026-11-04

Is Stock Locations for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.2)

As of 2026-11-04. 3 issues are on record for older versions; version 3.1.9 or newer fixes all of them that state a fix.

Latest version
3.2.2
Last updated
2026-10-31
Active installs
800+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

This plugin will help you to manage WooCommerce Products stocks through locations. — by Fahad Mahmood

What to do

  1. Update to the latest version (3.2.2). Anything older than 3.1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get stock-locations-for-woocommerce --field=version shows what you run; wp plugin update stock-locations-for-woocommerce updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-57419 · published 2026-07-13

Missing authorization check in Stock Locations for WooCommerce (3.1.8 and older)

Affected
3.1.8 and older
Fixed in
3.1.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fahad Mahmood Stock Locations for WooCommerce stock-locations-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Stock Locations for WooCommerce: from n/a through <= 3.1.8.

NVD CVE-2026-57419Patchstack advisory

high 7.1 CVE-2025-47463 · published 2025-06-09

Missing authorization check in Stock Locations for WooCommerce (2.8.6 and older)

Affected
2.8.6 and older
Fixed in
2.8.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fahad Mahmood Stock Locations for WooCommerce stock-locations-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Stock Locations for WooCommerce: from n/a through <= 2.8.6.

NVD CVE-2025-47463Patchstack advisory

medium 4.8 CVE-2024-22153 · published 2024-01-31

Stored cross-site scripting (XSS) in Stock Locations for WooCommerce (2.5.9 and older)

Affected
2.5.9 and older
Fixed in
2.6.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Fahad Mahmood & Alexandre Faustino Stock Locations for WooCommerce allows Stored XSS.This issue affects Stock Locations for WooCommerce: from n/a through 2.5.9.

NVD CVE-2024-22153Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Stock Locations for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/stock-locations-for-woocommerce"><img src="https://laskyr.com/plugins/stock-locations-for-woocommerce/badge.svg" alt="Stock Locations for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit