Plugins · sticky-chat-widget · data as of 2026-11-04
Is Sticky Chat Widget safe? Known vulnerabilities and latest version
- Latest version
- 1.4.4
- Last updated
- 2026-08-31
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 5.4+
Social chat buttons with WhatsApp, Messenger, WeChat, Telegram, Instagram, TikTok, Zalo & more — plus SMS, Call button, Contact form, and 20+ icons. — by gingerplugins
What to do
- Update to the latest version (1.4.4). Anything older than 1.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get sticky-chat-widget --field=version shows what you run; wp plugin update sticky-chat-widget updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-15462 · published 2026-09-11
SQL injection in Sticky Chat Widget (1.4.2 and older)
- Affected
- 1.4.2 and older
- Fixed in
- 1.4.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Sticky Chat Widget plugin for WordPress is vulnerable to SQL Injection via the 'scw_form_fields' parameter array keys of the 'scw_save_form_data' AJAX action in versions up to, and including, 1.4.2. This is due to the save_form_data() function passing attacker-controlled POST array keys unsanitized to $wpdb->insert(), which wraps column identifiers in backticks without escaping them, allowing a backtick in an attacker-supplied key to break out of the column-identifier list into raw SQL; additionally, the use of filter_input() bypasses WordPress's wp_magic_quotes() protection, and the widget_id validation loop is skipped entirely when no valid widget_id is supplied, leaving $isValid at 1. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2026-15462Wordfence advisoryCode change (fix)Plugin source
critical 9.3 CVE-2026-73187 · published 2026-08-18
SQL injection in Sticky Chat Widget (1.4.2 and older)
- Affected
- 1.4.2 and older
- Fixed in
- 1.4.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated SQL Injection in Sticky Chat Widget <= 1.4.2 versions.
medium 4.8 CVE-2023-51361 · published 2023-12-29
Stored cross-site scripting (XSS) in Sticky Chat Widget (1.1.8 and older)
- Affected
- 1.1.8 and older
- Fixed in
- 1.1.9
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ginger Plugins Sticky Chat Widget: Click to chat, SMS, Email, Messages, Call Button, Live Chat and Live Support Button allows Stored XSS.This issue affects Sticky Chat Widget: Click to chat, SMS, Email, Messages, Call Button, Live Chat and Live Support Button: from n/a through 1.1.8.
Recent activity
- 2026-08-31 — latest release on wordpress.org (1.4.4).
- 2026-09-11 — SQL injection disclosed (CVE-2026-15462), fixed in 1.4.3.
- 2026-08-18 — SQL injection disclosed (CVE-2026-73187), fixed in 1.4.3.
- 2023-12-29 — Stored cross-site scripting (XSS) disclosed (CVE-2023-51361), fixed in 1.1.9.
Get an email when Sticky Chat Widget has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Sticky Chat Widget (sticky-chat-widget) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/sticky-chat-widget (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/sticky-chat-widget"><img src="https://laskyr.com/plugins/sticky-chat-widget/badge.svg" alt="Sticky Chat Widget vulnerability status"></a>