Skip to content
Laskyr

Plugins · starfish-reviews · data as of 2026-11-04

Is Starfish Review Generation & Marketing for Wor… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.34)

As of 2026-11-04. 2 issues are on record for older versions; version 3.1.20 or newer fixes all of them that state a fix.

Latest version
3.1.34
Last updated
2026-11-03
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

The best WordPress plugin for generating 5-star customer reviews on Google, Facebook, Tripadvisor, and many more platforms. — by Starfish Reviews

What to do

  1. Update to the latest version (3.1.34). Anything older than 3.1.20 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get starfish-reviews --field=version shows what you run; wp plugin update starfish-reviews updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2025-15157 · published 2026-02-13

Privilege escalation in Starfish Review Generation & Marketing for Wor… (3.1.19 and older)

Affected
3.1.19 and older
Fixed in
3.1.20 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Starfish Review Generation & Marketing for WordPress plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the 'srm_restore_options_defaults' function in all versions up to, and including, 3.1.19. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.

NVD CVE-2025-15157Wordfence advisoryPlugin source

high 8.8 CVE-2025-39533 · published 2025-04-17

Privilege escalation in Starfish Review Generation & Marketing for Wor… (3.1.19 and older)

Affected
3.1.19 and older
Fixed in
3.1.20
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Starfish Reviews Starfish Review Generation & Marketing starfish-reviews allows Privilege Escalation.This issue affects Starfish Review Generation & Marketing: from n/a through <= 3.1.19.

NVD CVE-2025-39533Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Starfish Review Generation & Marketing for Wor… vulnerability status badge
<a href="https://laskyr.com/plugins/starfish-reviews"><img src="https://laskyr.com/plugins/starfish-reviews/badge.svg" alt="Starfish Review Generation & Marketing for Wor… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit