Skip to content
Laskyr

Plugins · stackable-ultimate-gutenberg-blocks · data as of 2026-11-04

Is Stackable safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.20.3)

As of 2026-11-04. 7 issues are on record for older versions; version 3.19.6 or newer fixes all of them that state a fix.

Latest version
3.20.3
Last updated
2026-10-13
Active installs
100,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The complete website builder for the WordPress block editor. Build professional sites faster with powerful blocks, block styles, and a global design s … — by Benjamin Intal

What to do

  1. Update to the latest version (3.20.3). Anything older than 3.19.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get stackable-ultimate-gutenberg-blocks --field=version shows what you run; wp plugin update stackable-ultimate-gutenberg-blocks updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2025-47500 · published 2026-01-22

Stored cross-site scripting (XSS) in Stackable (3.19.5 and older)

Affected
3.19.5 and older
Fixed in
3.19.6
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Benjamin Intal Stackable stackable-ultimate-gutenberg-blocks allows Stored XSS.This issue affects Stackable: from n/a through <= 3.19.5.

NVD CVE-2025-47500Patchstack advisory

medium 4.3 CVE-2025-60094 · published 2025-09-26

Missing authorization check in Stackable (3.18.1 and older)

Affected
3.18.1 and older
Fixed in
3.19.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Benjamin Intal Stackable stackable-ultimate-gutenberg-blocks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Stackable: from n/a through <= 3.18.1.

NVD CVE-2025-60094Patchstack advisory

medium 4.3 CVE-2025-60095 · published 2025-09-26

Information disclosure in Stackable (3.18.1 and older)

Affected
3.18.1 and older
Fixed in
3.19.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Benjamin Intal Stackable stackable-ultimate-gutenberg-blocks allows Retrieve Embedded Sensitive Data.This issue affects Stackable: from n/a through <= 3.18.1.

NVD CVE-2025-60095Patchstack advisory

medium 5.4 CVE-2024-12117 · published 2025-01-22

Stored cross-site scripting (XSS) in Stackable (3.13.11 and older)

Affected
3.13.11 and older
Fixed in
3.13.12 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Stackable – Page Builder Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'title' parameter of the Button block in all versions up to, and including, 3.13.11 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-12117Wordfence advisoryCode change (fix)

medium 5.3 CVE-2024-8760 · published 2024-10-12

Cross-site request forgery (CSRF) in Stackable (3.13.6 and older)

Affected
3.13.6 and older
Fixed in
3.13.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Stackable – Page Builder Gutenberg Blocks plugin for WordPress is vulnerable to CSS Injection in all versions up to, and including, 3.13.6. This makes it possible for unauthenticated attackers to embed untrusted style information into comments resulting in a possibility of data exfiltration such as admin nonces with limited impact. These nonces could be used to perform CSRF attacks within a limited time window. The presence of other plugins may make additional nonces available, which may pose a risk in plugins that don't perform capability checks to protect AJAX actions or other actions reachable by lower-privileged users.

NVD CVE-2024-8760Wordfence advisoryCode change (fix)

medium 6.4 CVE-2024-6296 · published 2024-06-28

Stored cross-site scripting (XSS) in Stackable (3.13.1 and older)

Affected
3.13.1 and older
Fixed in
3.13.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Stackable – Page Builder Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘data-caption’ parameter in all versions up to, and including, 3.13.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-6296Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2024-2039 · published 2024-04-09

Stored cross-site scripting (XSS) in Stackable (3.12.11 and older)

Affected
3.12.11 and older
Fixed in
3.12.12 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Stackable – Page Builder Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Post(v2) block title tag in all versions up to, and including, 3.12.11 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2039Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Stackable vulnerability status badge
<a href="https://laskyr.com/plugins/stackable-ultimate-gutenberg-blocks"><img src="https://laskyr.com/plugins/stackable-ultimate-gutenberg-blocks/badge.svg" alt="Stackable vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit