Plugins · ssl-zen · data as of 2026-11-04
Is SSL Zen safe? Known vulnerabilities and latest version
- Latest version
- 4.7.43
- Last updated
- 2026-09-18
- Active installs
- 9,000+
- Known issues on record
- 6
- Unpatched in latest
- 1
- Tested up to WP
- 7.0.8 · PHP 5.6+
Free SSL certificate for WordPress — install a Let's Encrypt SSL, force HTTPS, fix mixed content and redirect HTTP to HTTPS. No coding needed. — by SSL Zen - Free SSL/HTTPS
What to do
- There is no fixed version yet. If you can live without SSL Zen for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get ssl-zen --field=version shows what you run; wp plugin update ssl-zen updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-17577 · published 2026-09-25
Reflected cross-site scripting (XSS) in SSL Zen (4.7.42 and older)
- Affected
- 4.7.42 and older
- Fixed in
- 4.7.43 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SSL Zen plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'uri' (and 'host') parameters in versions up to, and including, 4.7.42. The ssl_zen_messages::getMessages() function builds the 'token_missmatch' message using base64_decode(sanitize_text_field($_REQUEST['uri'])) and (optionally) base64_decode(sanitize_text_field($_REQUEST['host'])). sanitize_text_field() cannot strip HTML/JavaScript that is hidden inside a base64-encoded blob, and the resulting decoded raw HTML is echoed unescaped by showMessage() . This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a specially crafted link.
NVD CVE-2026-17577Wordfence advisoryCode change (fix)Plugin source
medium 4.9 CVE-2026-17602 · published 2026-09-25
Path traversal / file read in SSL Zen (4.7.42 and older)
- Affected
- 4.7.42 and older
- Fixed in
- 4.7.43 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SSL Zen — SSL Certificate Installer & HTTPS Redirects plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 4.7.42 via the 'file_name' parameter parameter. This makes it possible for authenticated attackers, with administrator-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
NVD CVE-2026-17602Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2026-15463 · published 2026-09-19
Reflected cross-site scripting (XSS) in SSL Zen (4.7.42 and older)
- Affected
- 4.7.42 and older
- Fixed in
- 4.7.43 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SSL Zen — SSL Certificate Installer & HTTPS Redirects plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'host' parameter in all versions up to, and including, 4.7.42 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. The vulnerability is only exploitable when in the system_requirements stage.
NVD CVE-2026-15463Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-86781 · published 2026-09-11
Authentication bypass in SSL Zen (older than 4.7.40)
- Affected
- older than 4.7.40
- Fixed in
- 4.7.40
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The SSL Zen — SSL Certificate Installer & HTTPS Redirects WordPress plugin before 4.7.40 does not perform capability or nonce checks on a certificate-file download routine that runs early in the WordPress admin request lifecycle, allowing any authenticated user, including Subscribers, to download the site's TLS private key, certificates, and diagnostic logs.
high 7.1 affects latest 4.7.43 CVE-2026-28569 · published 2026-08-18
Cross-site scripting (XSS) in SSL Zen (4.7.43 and older)
- Affected
- 4.7.43 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in SSL Zen <= 4.7.43 versions.
medium 6.5 CVE-2024-1076 · published 2024-05-08
Authentication bypass in SSL Zen (older than 4.6.0)
- Affected
- older than 4.6.0
- Fixed in
- 4.6.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The SSL Zen WordPress plugin before 4.6.0 does not properly prevent directory listing of the private keys folder, as it only relies on the use of .htaccess to prevent visitors from accessing the site's generated private keys, which allows an attacker to read them if the site runs on a server who doesn't support .htaccess files, like NGINX.
Recent activity
- 2026-09-18 — latest release on wordpress.org (4.7.43).
- 2026-09-25 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-17577), fixed in 4.7.43.
- 2026-09-25 — Path traversal / file read disclosed (CVE-2026-17602), fixed in 4.7.43.
- 2026-09-19 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-15463), fixed in 4.7.43.
Get an email when SSL Zen has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for SSL Zen (ssl-zen) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Authentication bypass (2) · Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ssl-zen (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ssl-zen"><img src="https://laskyr.com/plugins/ssl-zen/badge.svg" alt="SSL Zen vulnerability status"></a>