Skip to content
Laskyr

Plugins · sql-chart-builder · data as of 2026-11-04

Is SQL Chart Builder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.7)

As of 2026-11-04. 4 issues are on record for older versions; version 3.0.7 or newer fixes all of them that state a fix.

Latest version
3.0.7
Last updated
2026-10-03
Active installs
500+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

Turn your SQL queries into beautiful dynamic charts with a visual SQL builder, live autocomplete and no-code date/input filters. — by Elvin Haci

What to do

  1. Update to the latest version (3.0.7). Anything older than 3.0.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sql-chart-builder --field=version shows what you run; wp plugin update sql-chart-builder updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-100158 · published 2026-10-16

Stored cross-site scripting (XSS) in SQL Chart Builder (3.0.6 and older)

Affected
3.0.6 and older
Fixed in
3.0.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SQL Chart Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'X-axis column value ($value->$xarg_s from $wpdb->get_results())' parameter in all versions up to, and including, 3.0.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires an administrator to have published a chart whose SQL query returns a column controllable by a lower-privileged user, such as wp_users.display_name, which a Subscriber can populate with a payload via the standard WordPress profile page at /wp-admin/profile.php.

NVD CVE-2026-100158Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-4079 · published 2026-04-07

SQL injection in SQL Chart Builder (older than 2.3.8)

Affected
older than 2.3.8
Fixed in
2.3.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The SQL Chart Builder WordPress plugin before 2.3.8 does not properly escape user input as it is concatened to SQL queries, making it possible for attackers to conduct SQL Injection attacks against the dynamic filter functionality.

NVD CVE-2026-4079WPScan advisory

medium 6.5 CVE-2025-58233 · published 2025-09-22

Cross-site scripting (XSS) in SQL Chart Builder (2.3.7.2 and older)

Affected
2.3.7.2 and older
Fixed in
2.3.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Guaven Labs SQL Chart Builder sql-chart-builder allows DOM-Based XSS.This issue affects SQL Chart Builder: from n/a through <= 2.3.7.2.

NVD CVE-2025-58233Patchstack advisory

medium 6.5 CVE-2024-11430 · published 2024-12-12

SQL injection in SQL Chart Builder (2.3.6 and older)

Affected
2.3.6 and older
Fixed in
2.3.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SQL Chart Builder plugin for WordPress is vulnerable to SQL Injection via the 'arg1' arg of the 'gvn_schart_2' shortcode in all versions up to, and including, 2.3.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2024-11430Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SQL Chart Builder vulnerability status badge
<a href="https://laskyr.com/plugins/sql-chart-builder"><img src="https://laskyr.com/plugins/sql-chart-builder/badge.svg" alt="SQL Chart Builder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit