Skip to content
Laskyr

Plugins · sprout-clients · data as of 2026-11-04

Is Sprout Clients safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.4)

As of 2026-11-04. 4 issues are on record for older versions; version 3.2.4 or newer fixes all of them that state a fix.

Latest version
3.2.4
Last updated
2026-08-18
Active installs
30+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

Properly leveraging your contact lists isn’t sending out a single email to the entire list asking for work — instead you need to build business relati … — by BoldGrid

What to do

  1. Update to the latest version (3.2.4). Anything older than 3.2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sprout-clients --field=version shows what you run; wp plugin update sprout-clients updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-57428 · published 2026-07-23

Cross-site scripting (XSS) in Sprout Clients (3.2.3 and older)

Affected
3.2.3 and older
Fixed in
3.2.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Sprout Clients <= 3.2.3 versions.

NVD CVE-2026-57428Patchstack advisory

medium 6.5 CVE-2026-32424 · published 2026-03-13

Stored cross-site scripting (XSS) in Sprout Clients (3.2.2 and older)

Affected
3.2.2 and older
Fixed in
3.2.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BoldGrid Sprout Clients sprout-clients allows Stored XSS.This issue affects Sprout Clients: from n/a through <= 3.2.2.

NVD CVE-2026-32424Patchstack advisory

high 7.1 CVE-2025-66118 · published 2025-12-18

Reflected cross-site scripting (XSS) in Sprout Clients (3.2.1 and older)

Affected
3.2.1 and older
Fixed in
3.2.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BoldGrid Sprout Clients sprout-clients allows Reflected XSS.This issue affects Sprout Clients: from n/a through <= 3.2.1.

NVD CVE-2025-66118Patchstack advisory

medium 6.5 CVE-2025-31797 · published 2025-04-01

Stored cross-site scripting (XSS) in Sprout Clients (3.2 and older)

Affected
3.2 and older
Fixed in
3.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BoldGrid Sprout Clients sprout-clients allows Stored XSS.This issue affects Sprout Clients: from n/a through <= 3.2.

NVD CVE-2025-31797Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Sprout Clients vulnerability status badge
<a href="https://laskyr.com/plugins/sprout-clients"><img src="https://laskyr.com/plugins/sprout-clients/badge.svg" alt="Sprout Clients vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit