Plugins · speedycache · data as of 2026-11-01
Is SpeedyCache safe? Known vulnerabilities and latest version
- Latest version
- 1.4.3
- Last updated
- 2026-10-08
- Active installs
- 500,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
SpeedyCache is a WordPress cache plugin that helps you improve performance of your WordPress site by caching, minifying, and compressing your website. — by Softaculous
What to do
- Update to the latest version (1.4.3). Anything older than 1.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get speedycache --field=version shows what you run; wp plugin update speedycache updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
low 3.7 CVE-2026-104006 · published 2026-10-10
Information disclosure in SpeedyCache (1.4.2 and older)
- Affected
- 1.4.2 and older
- Fixed in
- 1.4.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SpeedyCache – Cache, Optimization, Performance plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.4.2 via the 'comment_author_*, comment_author_email_*' parameter. This makes it possible for unauthenticated attackers to extract the full name and email address of returning commenters pre-filled into comment form input fields and persisted as the site-wide cached page by any unauthenticated attacker requesting the same public URL. The read-side handler in advanced-cache.php correctly skips cached delivery for requests carrying comment_author_* cookies, but this check is absent on the write path, meaning the cache poisoning is invisible to the victim commenter yet fully exploitable by any unauthenticated attacker with no cookies.
NVD CVE-2026-104006Wordfence advisoryCode change (fix)Plugin source
medium 4.9 CVE-2026-5114 · published 2026-07-28
Path traversal / file read in SpeedyCache (1.3.8 and older)
- Affected
- 1.3.8 and older
- Fixed in
- 1.3.9 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SpeedyCache plugin for WordPress is vulnerable to Arbitrary File Read via Path Traversal in all versions up to, and including, 1.3.8. This is due to a mismatch between CSS URL validation (which allows query strings like `.css?...`) and path resolution (which strips query strings), combined with no validation that the resolved file is actually a CSS file. This makes it possible for authenticated attackers, with Administrator-level access and above, to read arbitrary files from the server (including `wp-config.php` and `/etc/passwd`) by injecting crafted `<link>` tags into page content, with the file contents written to publicly accessible cache files.
medium 5.4 CVE-2024-43299 · published 2024-08-26
Cross-site request forgery (CSRF) in SpeedyCache (1.1.8 and older)
- Affected
- 1.1.8 and older
- Fixed in
- 1.1.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Softaculous SpeedyCache speedycache.This issue affects SpeedyCache: from n/a through <= 1.1.8.
medium 4.3 CVE-2023-6598 · published 2024-01-11
Missing authorization check in SpeedyCache (1.1.3 and older)
- Affected
- 1.1.3 and older
- Fixed in
- 1.1.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The SpeedyCache plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the speedycache_save_varniship, speedycache_img_update_settings, speedycache_preloading_add_settings, and speedycache_preloading_delete_resource functions in all versions up to, and including, 1.1.3. This makes it possible for authenticated attackers, with subscriber-level access and above, to update plugin options.
medium 4.3 CVE-2023-49746 · published 2023-12-07
Server-side request forgery (SSRF) in SpeedyCache (1.1.2 and older)
- Affected
- 1.1.2 and older
- Fixed in
- 1.1.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in Softaculous Team SpeedyCache – Cache, Optimization, Performance.This issue affects SpeedyCache – Cache, Optimization, Performance: from n/a through 1.1.2.
Recent activity
- 2026-10-08 — latest release on wordpress.org (1.4.3).
- 2026-10-10 — Information disclosure disclosed (CVE-2026-104006), fixed in 1.4.3.
- 2026-07-28 — Path traversal / file read disclosed (CVE-2026-5114), fixed in 1.3.9.
- 2024-08-26 — Cross-site request forgery (CSRF) disclosed (CVE-2024-43299), fixed in 1.1.9.
Get an email when SpeedyCache has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for SpeedyCache (speedycache) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/speedycache (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/speedycache"><img src="https://laskyr.com/plugins/speedycache/badge.svg" alt="SpeedyCache vulnerability status"></a>