Skip to content
Laskyr

Plugins · speakout · data as of 2026-11-04

Is SpeakOut! Email Petitions safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.6.6)

As of 2026-11-04. 3 issues are on record for older versions; version 4.6.5.1 or newer fixes all of them that state a fix.

Latest version
4.6.6
Last updated
2026-09-15
Active installs
2,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

SpeakOut! Email Petitions makes it easy to add petitions to your website and rally your community to Speak Out about a cause by using direct action. — by DigitalME

What to do

  1. Update to the latest version (4.6.6). Anything older than 4.6.5.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get speakout --field=version shows what you run; wp plugin update speakout updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.3 CVE-2026-39530 · published 2026-06-15

SQL injection in SpeakOut! Email Petitions (4.6.5 and older)

Affected
4.6.5 and older
Fixed in
4.6.5.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in SpeakOut! Email Petitions <= 4.6.5 versions.

NVD CVE-2026-39530Patchstack advisory

medium 6.5 CVE-2025-22309 · published 2025-01-07

Cross-site scripting (XSS) in SpeakOut! Email Petitions (4.4.2 and older)

Affected
4.4.2 and older
Fixed in
4.5.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in RopeSwingHld SpeakOut! Email Petitions speakout allows DOM-Based XSS.This issue affects SpeakOut! Email Petitions: from n/a through <= 4.4.2.

NVD CVE-2025-22309Patchstack advisory

critical 9.8 CVE-2022-0846 · published 2022-03-28

SQL injection in SpeakOut! Email Petitions (older than 2.14.15.1)

Affected
older than 2.14.15.1
Fixed in
2.14.15.1
Access needed (per CVSS)
No login needed
Range from
advisory text · score by NVD
Details from the advisory

The SpeakOut! Email Petitions WordPress plugin before 2.14.15.1 does not sanitise and escape the id parameter before using it in a SQL statement via the dk_speakout_sendmail AJAX action, leading to an SQL Injection exploitable by unauthenticated users

NVD CVE-2022-0846WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SpeakOut! Email Petitions vulnerability status badge
<a href="https://laskyr.com/plugins/speakout"><img src="https://laskyr.com/plugins/speakout/badge.svg" alt="SpeakOut! Email Petitions vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit