Skip to content
Laskyr

Plugins · soliloquy-lite · data as of 2026-11-04

Is Slider by Soliloquy safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.8.6)

As of 2026-11-04. 3 issues are on record for older versions; version 2.8.2 or newer fixes all of them that state a fix.

Latest version
2.8.6
Last updated
2026-10-23
Active installs
30,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

The best WordPress slider plugin. Drag & Drop responsive slider builder that helps you create a beautiful image slideshows with just a few clicks. — by Syed Balkhi

What to do

  1. Update to the latest version (2.8.6). Anything older than 2.8.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get soliloquy-lite --field=version shows what you run; wp plugin update soliloquy-lite updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-7636 · published 2026-05-22

Information disclosure in Slider by Soliloquy (2.8.1 and older)

Affected
2.8.1 and older
Fixed in
2.8.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Slider by Soliloquy – Responsive Image Slider for WordPress plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.8.1 via the map_meta_cap. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract draft slider metadata including unpublished media URLs, captions, and slider configuration authored by administrators or editors.

NVD CVE-2026-7636Wordfence advisoryCode change (fix)Plugin source

medium 5.9 CVE-2024-35775 · published 2024-08-12

Cross-site scripting (XSS) in Slider by Soliloquy (2.7.6 and older)

Affected
2.7.6 and older
Fixed in
2.7.7
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting'), Improper Authentication vulnerability in Soliloquy Team Slider by Soliloquy allows Cross-Site Scripting (XSS).This issue affects Slider by Soliloquy: from n/a through 2.7.6.

NVD CVE-2024-35775Patchstack advisory

medium 4.3 CVE-2023-51519 · published 2024-06-11

Missing authorization check in Slider by Soliloquy (2.7.2 and older)

Affected
2.7.2 and older
Fixed in
2.7.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Soliloquy Team Slider by Soliloquy.This issue affects Slider by Soliloquy: from n/a through 2.7.2.

NVD CVE-2023-51519Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Slider by Soliloquy vulnerability status badge
<a href="https://laskyr.com/plugins/soliloquy-lite"><img src="https://laskyr.com/plugins/soliloquy-lite/badge.svg" alt="Slider by Soliloquy vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit