Skip to content
Laskyr

Plugins · social-rocket · data as of 2026-11-04

Is Social Rocket safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.6)

As of 2026-11-04. 7 issues are on record for older versions; version 1.3.6 or newer fixes all of them that state a fix.

Latest version
1.3.6
Last updated
2026-10-06
Active installs
1,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.5+

Add fully-customizable social sharing buttons to your site. Easy to use and packed with many additional social networking features. — by socialrocket

What to do

  1. Update to the latest version (1.3.6). Anything older than 1.3.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get social-rocket --field=version shows what you run; wp plugin update social-rocket updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-42418 · published 2026-10-06

Reflected cross-site scripting (XSS) in Social Rocket (1.3.5 and older)

Affected
1.3.5 and older
Fixed in
1.3.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Socialrocket Social Rocket social-rocket allows Reflected XSS.This issue affects Social Rocket: from n/a through 1.3.5.

NVD CVE-2026-42418Patchstack advisory

medium 6.4 CVE-2026-1923 · published 2026-04-23

Stored cross-site scripting (XSS) in Social Rocket (1.3.4.2 and older)

Affected
1.3.4.2 and older
Fixed in
1.3.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Social Rocket – Social Sharing Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘id’ parameter in all versions up to, and including, 1.3.4.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1923Wordfence advisoryCode change (fix)

medium 5.3 CVE-2024-9697 · published 2025-01-07

Missing authorization check in Social Rocket (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.4.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Social Rocket – Social Sharing Plugin plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the tweet_settings_save() and tweet_settings_update() functions in all versions up to, and including, 1.3.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the plugin's settings.

NVD CVE-2024-9697Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-9702 · published 2025-01-07

Stored cross-site scripting (XSS) in Social Rocket (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Social Rocket – Social Sharing Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'socialrocket-floating' shortcode in all versions up to, and including, 1.3.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-9702Wordfence advisoryCode change (fix)

medium 6.1 CVE-2024-37258 · published 2024-07-22

Reflected cross-site scripting (XSS) in Social Rocket (1.3.3 and older)

Affected
1.3.3 and older
Fixed in
1.3.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Social Rocket allows Reflected XSS.This issue affects Social Rocket: from n/a through 1.3.3.

NVD CVE-2024-37258Patchstack advisory

medium 4.8 CVE-2022-3136 · published 2022-10-10

Stored cross-site scripting (XSS) in Social Rocket (older than 1.3.3)

Affected
older than 1.3.3
Fixed in
1.3.3
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The Social Rocket WordPress plugin before 1.3.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

NVD CVE-2022-3136WPScan advisory

high 8.8 CVE-2020-5611 · published 2020-07-27

Cross-site request forgery (CSRF) in Social Rocket (older than 1.2.10)

Affected
older than 1.2.10
Fixed in
1.2.10
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

Cross-site request forgery (CSRF) vulnerability in Social Sharing Plugin versions prior to 1.2.10 allows remote attackers to hijack the authentication of administrators via unspecified vectors.

NVD CVE-2020-5611wordpress.orgjvn.jp

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Social Rocket vulnerability status badge
<a href="https://laskyr.com/plugins/social-rocket"><img src="https://laskyr.com/plugins/social-rocket/badge.svg" alt="Social Rocket vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit