Plugins · social-pug · data as of 2026-11-04
Is Hubbub Lite safe? Known vulnerabilities and latest version
- Latest version
- 1.36.3.1
- Last updated
- 2026-09-14
- Active installs
- 30,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2.24+
Your content is worth sharing. Let's makes it easier! — by NerdPress
What to do
- Update to the latest version (1.36.3.1). Anything older than 1.36.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get social-pug --field=version shows what you run; wp plugin update social-pug updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-27403 · published 2026-07-23
Stored cross-site scripting (XSS) in Hubbub Lite (1.36.3 and older)
- Affected
- 1.36.3 and older
- Fixed in
- 1.36.3.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in NerdPress Hubbub Lite allows Stored XSS. This issue affects Hubbub Lite: from n/a through 1.36.3.
medium 6.1 CVE-2025-12471 · published 2025-11-06
Reflected cross-site scripting (XSS) in Hubbub Lite (1.36.0 and older)
- Affected
- 1.36.0 and older
- Fixed in
- 1.36.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Hubbub Lite – Fast, free social sharing and follow buttons plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'dpsp_list_attention_search' parameter in all versions up to, and including, 1.36.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2025-12471Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-58007 · published 2025-09-22
Information disclosure in Hubbub Lite (1.35.2 and older)
- Affected
- 1.35.2 and older
- Fixed in
- 1.36.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in NerdPress Hubbub Lite social-pug allows Retrieve Embedded Sensitive Data.This issue affects Hubbub Lite: from n/a through <= 1.35.2.
medium 4.8 CVE-2024-10145 · published 2025-05-15
Stored cross-site scripting (XSS) in Hubbub Lite (older than 1.34.4)
- Affected
- older than 1.34.4
- Fixed in
- 1.34.4
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Hubbub Lite WordPress plugin before 1.34.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
medium 5.3 CVE-2023-49193 · published 2024-12-09
Missing authorization check in Hubbub Lite (1.30.0 and older)
- Affected
- 1.30.0 and older
- Fixed in
- 1.30.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in NerdPress Hubbub Lite social-pug allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Hubbub Lite: from n/a through <= 1.30.0.
high 7.5 CVE-2024-2501 · published 2024-04-09
PHP object injection in Hubbub Lite (1.33.1 and older)
- Affected
- 1.33.1 and older
- Fixed in
- 1.33.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Hubbub Lite – Fast, Reliable Social Sharing Buttons plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.33.1 via deserialization of untrusted input via the 'dpsp_maybe_unserialize' function. This makes it possible for authenticated attackers, with contributor access and above, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
NVD CVE-2024-2501Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2024-1526 · published 2024-04-01
Security issue in Hubbub Lite (older than 1.33.1)
- Affected
- older than 1.33.1
- Fixed in
- 1.33.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Hubbub Lite WordPress plugin before 1.33.1 does not ensure that user have access to password protected post before displaying its content in a meta tag.
Recent activity
- 2026-09-14 — latest release on wordpress.org (1.36.3.1).
- 2026-07-23 — Stored cross-site scripting (XSS) disclosed (CVE-2026-27403), fixed in 1.36.3.1.
- 2025-11-06 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-12471), fixed in 1.36.1.
- 2025-09-22 — Information disclosure disclosed (CVE-2025-58007), fixed in 1.36.0.
Get an email when Hubbub Lite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Hubbub Lite (social-pug) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Sensitive data exposure (1) · Missing authorization (1) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/social-pug (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/social-pug"><img src="https://laskyr.com/plugins/social-pug/badge.svg" alt="Hubbub Lite vulnerability status"></a>