Skip to content
Laskyr

Plugins · social-post-embed · data as of 2026-11-04

Is Social Post Embed safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.2)

As of 2026-11-04. 1 issue is on record for older versions; version 2.0.2 or newer fixes all of them that state a fix.

Latest version
2.0.2
Last updated
2026-08-20
Active installs
500+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Add embedding for various social media platforms to your WordPress posts. — by David Artiss

What to do

  1. Update to the latest version (2.0.2). Anything older than 2.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get social-post-embed --field=version shows what you run; wp plugin update social-post-embed updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-6809 · published 2026-04-28

Stored cross-site scripting (XSS) in Social Post Embed (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Social Post Embed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Threads embed handler in all versions up to, and including, 2.0.1. This is due to insufficient input sanitization and output escaping on the user-supplied URL. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-6809Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Social Post Embed vulnerability status badge
<a href="https://laskyr.com/plugins/social-post-embed"><img src="https://laskyr.com/plugins/social-post-embed/badge.svg" alt="Social Post Embed vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit