Skip to content
Laskyr

Plugins · social-polls-by-opinionstage · data as of 2026-11-04

Is Quiz Maker, Poll Maker & Survey Maker by Opini… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (19.12.8)

As of 2026-11-04. 4 issues are on record for older versions; version 19.12.1 or newer fixes all of them that state a fix.

Latest version
19.12.8
Last updated
2026-09-11
Active installs
6,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Boost engagement and capture leads with interactive quizzes, polls, and surveys. Built for marketers, publishers, and businesses — by Opinion Stage

What to do

  1. Update to the latest version (19.12.8). Anything older than 19.12.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get social-polls-by-opinionstage --field=version shows what you run; wp plugin update social-polls-by-opinionstage updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-68594 · published 2025-12-24

Missing authorization check in Quiz Maker, Poll Maker & Survey Maker by Opini… (19.12.0 and older)

Affected
19.12.0 and older
Fixed in
19.12.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Opinion Stage Poll, Survey & Quiz Maker Plugin by Opinion Stage social-polls-by-opinionstage allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Poll, Survey & Quiz Maker Plugin by Opinion Stage: from n/a through <= 19.12.0.

NVD CVE-2025-68594Patchstack advisory

medium 4.3 CVE-2025-13143 · published 2025-11-27

Cross-site request forgery (CSRF) in Quiz Maker, Poll Maker & Survey Maker by Opini… (19.12.0 and older)

Affected
19.12.0 and older
Fixed in
19.12.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Poll, Survey & Quiz Maker Plugin by Opinion Stage plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 19.12.0. This is due to missing or insufficient nonce validation on the disconnect_account_action function. This makes it possible for unauthenticated attackers to disconnect the site from the Opinion Stage platform integration via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-13143Wordfence advisoryPlugin source

high 7.5 CVE-2025-53328 · published 2025-08-28

File inclusion in Quiz Maker, Poll Maker & Survey Maker by Opini… (19.11.0 and older)

Affected
19.11.0 and older
Fixed in
19.11.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Opinion Stage Poll, Survey & Quiz Maker Plugin by Opinion Stage social-polls-by-opinionstage allows PHP Local File Inclusion.This issue affects Poll, Survey & Quiz Maker Plugin by Opinion Stage: from n/a through <= 19.11.0.

NVD CVE-2025-53328Patchstack advisory

medium 4.3 CVE-2025-3880 · published 2025-06-17

Missing authorization check in Quiz Maker, Poll Maker & Survey Maker by Opini… (19.9.0 and older)

Affected
19.9.0 and older
Fixed in
19.10.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Poll, Survey & Quiz Maker Plugin by Opinion Stage plugin for WordPress is vulnerable to unauthorized modification of data due to a misconfigured capability check on several functions in all versions up to, and including, 19.9.0. This makes it possible for authenticated attackers, with Contributor-level access and above, to change the email address for the account connection, and disconnect the plugin. Previously created content will still be displayed and functional if the account is disconnected.

NVD CVE-2025-3880Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Quiz Maker, Poll Maker & Survey Maker by Opini… vulnerability status badge
<a href="https://laskyr.com/plugins/social-polls-by-opinionstage"><img src="https://laskyr.com/plugins/social-polls-by-opinionstage/badge.svg" alt="Quiz Maker, Poll Maker & Survey Maker by Opini… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit