Skip to content
Laskyr

Plugins · social-photo-feed-widget · data as of 2026-11-04

Is Widgets for Social Photo Feed safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.3)

As of 2026-11-04. 3 issues are on record for older versions; version 1.8.2 or newer fixes all of them that state a fix.

Latest version
1.8.3
Last updated
2026-11-01
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Instagram Feed Widgets. Display your Instagram feed on your website to increase engagement, sales and SEO. — by Trustindex

What to do

  1. Update to the latest version (1.8.3). Anything older than 1.8.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get social-photo-feed-widget --field=version shows what you run; wp plugin update social-photo-feed-widget updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-14726 · published 2026-05-02

Missing authorization check in Widgets for Social Photo Feed (1.8 and older)

Affected
1.8 and older
Fixed in
1.8.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Widgets for Social Photo Feed plugin for WordPress is vulnerable to unauthorized access of data and modification of data due to a missing capability check on the '/trustindex_feed_hook_instagram/troubleshooting' and '/trustindex_feed_hook_instagram/submit-data' REST API endpoints in all versions up to, and including, 1.8. This makes it possible for unauthenticated attackers to access and update plugin settings.

NVD CVE-2025-14726Wordfence advisoryCode change (fix)

high 7.2 CVE-2026-5425 · published 2026-04-04

Stored cross-site scripting (XSS) in Widgets for Social Photo Feed (1.7.9 and older)

Affected
1.7.9 and older
Fixed in
1.8.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Widgets for Social Photo Feed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'feed_data' parameter keys in all versions up to, and including, 1.7.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-5425Wordfence advisoryCode change (fix)

medium 5.3 CVE-2025-68595 · published 2025-12-24

Missing authorization check in Widgets for Social Photo Feed (1.8 and older)

Affected
1.8 and older
Fixed in
1.8.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Trustindex Widgets for Social Photo Feed social-photo-feed-widget allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Widgets for Social Photo Feed: from n/a through <= 1.8.

NVD CVE-2025-68595Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Widgets for Social Photo Feed vulnerability status badge
<a href="https://laskyr.com/plugins/social-photo-feed-widget"><img src="https://laskyr.com/plugins/social-photo-feed-widget/badge.svg" alt="Widgets for Social Photo Feed vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit