Skip to content
Laskyr

Plugins · social-media-auto-publish · data as of 2026-11-04

Is Social Media Auto Publish safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.6.10)

As of 2026-11-04. 1 issue is on record for older versions; version 3.6.6 or newer fixes all of them that state a fix.

Latest version
3.6.10
Last updated
2026-06-25
Active installs
5,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.2+

Publish posts automatically to social media networks like Facebook, Twitter, Instagram, Tumblr, LinkedIn, Threads and Telegram. — by f1logic

What to do

  1. Update to the latest version (3.6.10). Anything older than 3.6.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get social-media-auto-publish --field=version shows what you run; wp plugin update social-media-auto-publish updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2025-12076 · published 2025-12-13

Reflected cross-site scripting (XSS) in Social Media Auto Publish (3.6.5 and older)

Affected
3.6.5 and older
Fixed in
3.6.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Social Media Auto Publish plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via PostMessage parameter in all versions up to, and including, 3.6.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2025-12076Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Social Media Auto Publish vulnerability status badge
<a href="https://laskyr.com/plugins/social-media-auto-publish"><img src="https://laskyr.com/plugins/social-media-auto-publish/badge.svg" alt="Social Media Auto Publish vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit