Skip to content
Laskyr

Plugins · social-icons-widget-by-wpzoom · data as of 2026-11-04

Is WPZOOM Connect safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.0.0)

As of 2026-11-04. 3 issues are on record for older versions; version 4.7.4 or newer fixes all of them that state a fix.

Latest version
5.0.0
Last updated
2026-10-27
Active installs
90,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Social media icons and share buttons: 2,400+ icons, block, widget & Elementor. Plus a Click to Chat button for WhatsApp, Telegram & Messenger. — by WPZOOM

What to do

  1. Update to the latest version (5.0.0). Anything older than 4.7.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get social-icons-widget-by-wpzoom --field=version shows what you run; wp plugin update social-icons-widget-by-wpzoom updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-100149 · published 2026-10-03

Information disclosure in WPZOOM Connect (4.7.3 and older)

Affected
4.7.3 and older
Fixed in
4.7.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPZOOM Connect: AI Chat, Click to Chat, Social Icons & Share Buttons plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.7.3 via the 'x-yamidoo-signature (attacker-obtained via inline_js identify payload)' parameter. This makes it possible for unauthenticated attackers to extract the full customer card — including name, WordPress user ID, order history, order totals, purchased products, payment method labels, and EDD Software Licensing license keys with status and activation counts — for any arbitrary victim email address on the site. Exploitation requires the attacker to register a WooCommerce customer or subscriber-level account with a crafted email address whose local part encodes the target timestamp and victim email, allowing the signature printed into the page HTML by inline_js() to pass verify_request() for an arbitrary victim; both the share_customer_data and identify_logged_in settings are enabled by default, so no non-default configuration is required.

NVD CVE-2026-100149Wordfence advisorygithub.comPlugin source

medium 4.3 CVE-2026-4063 · published 2026-03-13

Missing authorization check in WPZOOM Connect (4.5.8 and older)

Affected
4.5.8 and older
Fixed in
4.5.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Social Icons Widget & Block by WPZOOM plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check in the add_menu_item() method hooked to admin_menu in all versions up to, and including, 4.5.8. This is due to the method performing wp_insert_post() and update_post_meta() calls to create a sharing configuration without verifying the current user has administrator-level capabilities. This makes it possible for authenticated attackers, with Subscriber-level access and above, to trigger the creation of a published wpzoom-sharing configuration post with default sharing button settings, which causes social sharing buttons to be automatically injected into all post content on the frontend via the the_content filter.

NVD CVE-2026-4063Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-30464 · published 2024-06-09

Missing authorization check in WPZOOM Connect (4.2.15 and older)

Affected
4.2.15 and older
Fixed in
4.2.16
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in WPZOOM Social Icons Widget & Block by WPZOOM.This issue affects Social Icons Widget & Block by WPZOOM: from n/a through 4.2.15.

NVD CVE-2024-30464Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPZOOM Connect vulnerability status badge
<a href="https://laskyr.com/plugins/social-icons-widget-by-wpzoom"><img src="https://laskyr.com/plugins/social-icons-widget-by-wpzoom/badge.svg" alt="WPZOOM Connect vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit