Plugins · so-css · data as of 2026-11-04
Is SiteOrigin CSS safe? Known vulnerabilities and latest version
- Latest version
- 1.6.8
- Last updated
- 2026-10-09
- Active installs
- 100,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0.0+
Powerful, simple CSS editing for WordPress. Visual controls & real-time previews for effortless site customization. — by Greg - SiteOrigin
What to do
- Update to the latest version (1.6.8). Anything older than 1.6.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get so-css --field=version shows what you run; wp plugin update so-css updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-111122 · published 2026-10-16
DOM-based cross-site scripting (XSS) in SiteOrigin CSS (1.6.7 and older)
- Affected
- 1.6.7 and older
- Fixed in
- 1.6.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SiteOrigin CSS plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'href' parameter in all versions up to, and including, 1.6.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the malicious comment to be approved and an administrator to subsequently open the Visual Inspector and click the attacker's anchor link, both of which are plausible interactions during routine comment triage.
NVD CVE-2026-111122Wordfence advisorygithub.comPlugin source
high 7.2 CVE-2026-107764 · published 2026-10-16
DOM-based cross-site scripting (XSS) in SiteOrigin CSS (1.6.7 and older)
- Affected
- 1.6.7 and older
- Fixed in
- 1.6.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SiteOrigin CSS plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'url (comment_author_url)' parameter in all versions up to, and including, 1.6.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because WordPress core's esc_url() preserves HTML entity-encoded characters, allowing a crafted entity-encoded payload in the comment 'Website' field to survive storage and be DOM-decoded by the browser into executable markup at the sink.
NVD CVE-2026-107764Wordfence advisorygithub.comPlugin source
Recent activity
- 2026-10-09 — latest release on wordpress.org (1.6.8).
- 2026-10-16 — DOM-based cross-site scripting (XSS) disclosed (CVE-2026-111122), fixed in 1.6.8.
- 2026-10-16 — DOM-based cross-site scripting (XSS) disclosed (CVE-2026-107764), fixed in 1.6.8.
Get an email when SiteOrigin CSS has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for SiteOrigin CSS (so-css) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Greg (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/so-css (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/so-css"><img src="https://laskyr.com/plugins/so-css/badge.svg" alt="SiteOrigin CSS vulnerability status"></a>