Skip to content
Laskyr

Plugins · snow-monkey-forms · data as of 2026-11-04

Is Snow Monkey Forms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (13.0.1)

As of 2026-11-04. 3 issues are on record for older versions; version 12.0.4 or newer fixes all of them that state a fix.

Latest version
13.0.1
Last updated
2026-10-28
Active installs
30,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The Snow Monkey Forms is a mail form plugin for the block editor. — by Takashi Kitajima

What to do

  1. Update to the latest version (13.0.1). Anything older than 12.0.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get snow-monkey-forms --field=version shows what you run; wp plugin update snow-monkey-forms updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-1056 · published 2026-01-28

Arbitrary file deletion in Snow Monkey Forms (12.0.3 and older)

Affected
12.0.3 and older
Fixed in
12.0.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Snow Monkey Forms plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'generate_user_dirpath' function in all versions up to, and including, 12.0.3. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).

NVD CVE-2026-1056Wordfence advisoryCode change (fix)Plugin source

critical 9.1 CVE-2023-32623 · published 2023-06-28

Path traversal / file read in Snow Monkey Forms (older than 5.1.2)

Affected
older than 5.1.2
Fixed in
5.1.2
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

Directory traversal vulnerability in Snow Monkey Forms v5.1.1 and earlier allows a remote unauthenticated attacker to delete arbitrary files on the server.

NVD CVE-2023-32623jvn.jpsnow-monkey.2inc.org

critical 9.8 CVE-2023-28413 · published 2023-05-23

Path traversal / file read in Snow Monkey Forms (5.0.6 and older)

Affected
5.0.6 and older
Fixed in
5.0.7 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

Directory traversal vulnerability in Snow Monkey Forms versions v5.0.6 and earlier allows a remote unauthenticated attacker to obtain sensitive information, alter the website, or cause a denial-of-service (DoS) condition.

NVD CVE-2023-28413jvn.jpsnow-monkey.2inc.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Snow Monkey Forms vulnerability status badge
<a href="https://laskyr.com/plugins/snow-monkey-forms"><img src="https://laskyr.com/plugins/snow-monkey-forms/badge.svg" alt="Snow Monkey Forms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit