Skip to content
Laskyr

Plugins · snow-monkey-blocks · data as of 2026-11-04

Is Snow Monkey Blocks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (26.0.3)

As of 2026-11-04. 1 issue is on record for older versions; version 24.1.12 or newer fixes all of them that state a fix.

Latest version
26.0.3
Last updated
2026-10-28
Active installs
30,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Gutenberg blocks collection made by MonkeyWrench. — by Takashi Kitajima

What to do

  1. Update to the latest version (26.0.3). Anything older than 24.1.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get snow-monkey-blocks --field=version shows what you run; wp plugin update snow-monkey-blocks updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-3004 · published 2026-05-13

Stored cross-site scripting (XSS) in Snow Monkey Blocks (24.1.11 and older)

Affected
24.1.11 and older
Fixed in
24.1.12 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Snow Monkey Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘data-slick' attribute in all versions up to, and including, 24.1.11 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-3004Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Snow Monkey Blocks vulnerability status badge
<a href="https://laskyr.com/plugins/snow-monkey-blocks"><img src="https://laskyr.com/plugins/snow-monkey-blocks/badge.svg" alt="Snow Monkey Blocks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit