Skip to content
Laskyr

Plugins · snillrik-restaurant-menu · data as of 2026-11-04

Is Snillrik Restaurant Menu safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.2)

As of 2026-11-04. 1 issue is on record for older versions; version 2.3.1 or newer fixes all of them that state a fix.

Latest version
2.3.2
Last updated
2026-05-21
Active installs
fewer than 10
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8

Easiest way to maintain a menu that changes every day, like a lunchmenu or "Today's special". — by mattiaspkallio

What to do

  1. Update to the latest version (2.3.2). Anything older than 2.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get snillrik-restaurant-menu --field=version shows what you run; wp plugin update snillrik-restaurant-menu updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-14112 · published 2026-01-07

Stored cross-site scripting (XSS) in Snillrik Restaurant Menu (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Snillrik Restaurant plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'menu_style' shortcode attribute in all versions up to, and including, 2.3.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-14112Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Snillrik Restaurant Menu vulnerability status badge
<a href="https://laskyr.com/plugins/snillrik-restaurant-menu"><img src="https://laskyr.com/plugins/snillrik-restaurant-menu/badge.svg" alt="Snillrik Restaurant Menu vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit