Plugins · smtp2go · data as of 2026-11-04
Is SMTP2GO for WordPress safe? Known vulnerabilities and latest version
- Latest version
- 1.17.1
- Last updated
- 2026-08-30
- Active installs
- 40,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Resolve email delivery issues, increase inbox placement, track sent email, get 24/7 support, and real-time reporting. — by SMTP2GO
What to do
- Update to the latest version (1.17.1). Anything older than 1.17.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get smtp2go --field=version shows what you run; wp plugin update smtp2go updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-7621 · published 2026-05-28
Missing authorization check in SMTP2GO for WordPress (1.16.0 and older)
- Affected
- 1.16.0 and older
- Fixed in
- 1.17.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SMTP2GO for WordPress – Email Made Easy plugin for WordPress is vulnerable to unauthorized access in all versions up to, and including, 1.16.0. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to truncate all SMTP2GO log records from the database or download a CSV export of all SMTP log data including recipient addresses, sender addresses, message subjects, and API response data.
NVD CVE-2026-7621Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-54011 · published 2025-07-16
Missing authorization check in SMTP2GO for WordPress (1.12.1 and older)
- Affected
- 1.12.1 and older
- Fixed in
- 1.12.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in SMTP2GO SMTP2GO smtp2go allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects SMTP2GO: from n/a through <= 1.12.1.
medium 4.8 CVE-2023-28496 · published 2023-06-22
Stored cross-site scripting (XSS) in SMTP2GO for WordPress (1.4.2 and older)
- Affected
- 1.4.2 and older
- Fixed in
- 1.5.0
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in SMTP2GO – Email Made Easy plugin <= 1.4.2 versions.
Recent activity
- 2026-08-30 — latest release on wordpress.org (1.17.1).
- 2026-05-28 — Missing authorization check disclosed (CVE-2026-7621), fixed in 1.17.0.
- 2025-07-16 — Missing authorization check disclosed (CVE-2025-54011), fixed in 1.12.2.
- 2023-06-22 — Stored cross-site scripting (XSS) disclosed (CVE-2023-28496), fixed in 1.5.0.
Get an email when SMTP2GO for WordPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for SMTP2GO for WordPress (smtp2go) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/smtp2go (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/smtp2go"><img src="https://laskyr.com/plugins/smtp2go/badge.svg" alt="SMTP2GO for WordPress vulnerability status"></a>