Plugins · smtp-mailer · data as of 2026-11-04
Is SMTP Mailer safe? Known vulnerabilities and latest version
- Latest version
- 1.1.28
- Last updated
- 2026-09-07
- Active installs
- 70,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Configure a SMTP server to send email from your WordPress site. Configure the wp_mail() function to use SMTP instead of the PHP mail() function. — by Noor Alam
What to do
- Update to the latest version (1.1.28). Anything older than 1.1.25 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get smtp-mailer --field=version shows what you run; wp plugin update smtp-mailer updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-32538 · published 2026-03-25
Information disclosure in SMTP Mailer (1.1.24 and older)
- Affected
- 1.1.24 and older
- Fixed in
- 1.1.25
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in Noor Alam SMTP Mailer smtp-mailer allows Retrieve Embedded Sensitive Data.This issue affects SMTP Mailer: from n/a through <= 1.1.24.
Recent activity
- 2026-09-07 — latest release on wordpress.org (1.1.28).
- 2026-03-25 — Information disclosure disclosed (CVE-2026-32538), fixed in 1.1.25.
Get an email when SMTP Mailer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for SMTP Mailer (smtp-mailer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Noor Alam (5 tracked)
Types found in this plugin: Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/smtp-mailer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/smtp-mailer"><img src="https://laskyr.com/plugins/smtp-mailer/badge.svg" alt="SMTP Mailer vulnerability status"></a>