Skip to content
Laskyr

Plugins · smartsupp-live-chat · data as of 2026-11-04

Is Smartsupp safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.10)

As of 2026-11-04. 2 issues are on record for older versions; version 3.9.2 or newer fixes all of them that state a fix.

Latest version
3.10
Last updated
2026-10-04
Active installs
20,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Boost your sales and turn visitors into customers with live chat, AI tools and chatbots. Smartsupp is trusted by 100,000+ online stores. — by Smartsupp

What to do

  1. Update to the latest version (3.10). Anything older than 3.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get smartsupp-live-chat --field=version shows what you run; wp plugin update smartsupp-live-chat updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-12448 · published 2026-02-19

Stored cross-site scripting (XSS) in Smartsupp (3.9.1 and older)

Affected
3.9.1 and older
Fixed in
3.9.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smartsupp – live chat, AI shopping assistant and chatbots plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'code' parameter in all versions up to, and including, 3.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-12448Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-38790 · published 2025-01-02

Cross-site request forgery (CSRF) in Smartsupp (3.6 and older)

Affected
3.6 and older
Fixed in
3.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Smartsupp Smartsupp – live chat, chatbots, AI and lead generation smartsupp-live-chat allows Cross Site Request Forgery.This issue affects Smartsupp – live chat, chatbots, AI and lead generation: from n/a through <= 3.6.

NVD CVE-2024-38790Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Smartsupp vulnerability status badge
<a href="https://laskyr.com/plugins/smartsupp-live-chat"><img src="https://laskyr.com/plugins/smartsupp-live-chat/badge.svg" alt="Smartsupp vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit