Skip to content
Laskyr

Plugins · smartcat-wpml · data as of 2026-11-04

Is Smartcat Translator for WPML safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.79)

As of 2026-11-04. 2 issues are on record for older versions; version 3.1.78 or newer fixes all of them that state a fix.

Latest version
3.1.79
Last updated
2026-10-19
Active installs
60+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.0+

The easiest way to translate your WPML-enabled WordPress site into various languages. — by smartcatai

What to do

  1. Update to the latest version (3.1.79). Anything older than 3.1.78 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get smartcat-wpml --field=version shows what you run; wp plugin update smartcat-wpml updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-4683 · published 2026-05-15

Missing authorization check in Smartcat Translator for WPML (3.1.77 and older)

Affected
3.1.77 and older
Fixed in
3.1.78 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smartcat Translator for WPML plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'routeData' REST endpoint in all versions up to, and including, 3.1.77. This makes it possible for unauthenticated attackers to overwrite the plugin's Smartcat API credentials (account ID, API secret key, hub key, API host, and hub host), effectively hijacking the translation service or causing a denial of service.

NVD CVE-2026-4683Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-9451 · published 2025-09-11

SQL injection in Smartcat Translator for WPML (3.1.72 and older)

Affected
3.1.72 and older
Fixed in
3.1.73 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smartcat Translator for WPML plugin for WordPress is vulnerable to time-based SQL Injection via the ‘orderby’ parameter in all versions up to, and including, 3.1.72 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Author-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-9451Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Smartcat Translator for WPML vulnerability status badge
<a href="https://laskyr.com/plugins/smartcat-wpml"><img src="https://laskyr.com/plugins/smartcat-wpml/badge.svg" alt="Smartcat Translator for WPML vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit