Skip to content
Laskyr

Plugins · smart-manager-for-wp-e-commerce · data as of 2026-11-04

Is Smart Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (8.98.0)

As of 2026-11-04. 7 issues are on record for older versions; version 8.98.0 or newer fixes all of them that state a fix.

Latest version
8.98.0
Last updated
2026-10-13
Active installs
10,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

WooCommerce Bulk Edit for products, orders, coupons & any WordPress post type — all in one Excel-like spreadsheet. Manage stock & pricing too. — by storeapps

What to do

  1. Update to the latest version (8.98.0). Anything older than 8.98.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get smart-manager-for-wp-e-commerce --field=version shows what you run; wp plugin update smart-manager-for-wp-e-commerce updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-18443 · published 2026-10-03

SQL injection in Smart Manager (8.97.0 and older)

Affected
8.97.0 and older
Fixed in
8.98.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smart Manager – Advanced WooCommerce Bulk Edit & Inventory Management plugin for WordPress is vulnerable to generic SQL Injection via the 'access_privileges' parameter in all versions up to, and including, 8.97.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This exploit is only possible on installations where an administrator has saved a role-based deny-list Access Privilege configuration that does not explicitly block the internal 'access-privilege' module, as this condition allows the authorization filter to implicitly permit Subscriber-level users to invoke the vulnerable handler.

NVD CVE-2026-18443Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2026-14203 · published 2026-07-27

Cross-site scripting (XSS) in Smart Manager (older than 8.92.0)

Affected
older than 8.92.0
Fixed in
8.92.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Smart Manager WordPress plugin before 8.92.0 does not properly encode a post field before rendering it into an HTML attribute in its management grid, allowing users with the Contributor role or above to inject JavaScript that executes in the browser session of an administrator who views the grid.

NVD CVE-2026-14203WPScan advisory

high 7.1 CVE-2026-57704 · published 2026-07-23

Cross-site scripting (XSS) in Smart Manager (8.90.0 and older)

Affected
8.90.0 and older
Fixed in
8.91.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Smart Manager <= 8.90.0 versions.

NVD CVE-2026-57704Patchstack advisory

high 8.8 CVE-2026-45216 · published 2026-05-25

Privilege escalation in Smart Manager (8.85.0 and older)

Affected
8.85.0 and older
Fixed in
8.86.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in StoreApps Smart Manager allows Privilege Escalation. This issue affects Smart Manager: from n/a through 8.85.0.

NVD CVE-2026-45216Patchstack advisory

high 7.6 CVE-2025-22710 · published 2025-01-21

SQL injection in Smart Manager (8.52.0 and older)

Affected
8.52.0 and older
Fixed in
8.53.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in storeapps Smart Manager smart-manager-for-wp-e-commerce allows Blind SQL Injection.This issue affects Smart Manager: from n/a through <= 8.52.0.

NVD CVE-2025-22710Patchstack advisory

medium 4.3 CVE-2024-49687 · published 2024-12-31

Missing authorization check in Smart Manager (8.45.0 and older)

Affected
8.45.0 and older
Fixed in
8.46.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in storeapps Smart Manager smart-manager-for-wp-e-commerce.This issue affects Smart Manager: from n/a through <= 8.45.0.

NVD CVE-2024-49687Patchstack advisory

high 7.2 CVE-2024-0566 · published 2024-02-12

SQL injection in Smart Manager (older than 8.28.0)

Affected
older than 8.28.0
Fixed in
8.28.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Smart Manager WordPress plugin before 8.28.0 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin.

NVD CVE-2024-0566WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Smart Manager vulnerability status badge
<a href="https://laskyr.com/plugins/smart-manager-for-wp-e-commerce"><img src="https://laskyr.com/plugins/smart-manager-for-wp-e-commerce/badge.svg" alt="Smart Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit