Skip to content
Laskyr

Plugins · smart-custom-fields · data as of 2026-11-04

Is Smart Custom Fields safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.0.8)

As of 2026-11-04. 4 issues are on record for older versions; version 5.0.8 or newer fixes all of them that state a fix.

Latest version
5.0.8
Last updated
2026-07-16
Active installs
50,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 7.4+

Smart Custom Fields is a simple plugin for managing custom fields. — by Takashi Kitajima

What to do

  1. Update to the latest version (5.0.8). Anything older than 5.0.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get smart-custom-fields --field=version shows what you run; wp plugin update smart-custom-fields updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-2594 · published 2026-07-17

Stored cross-site scripting (XSS) in Smart Custom Fields (5.0.7 and older)

Affected
5.0.7 and older
Fixed in
5.0.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smart Custom Fields plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 5.0.7. This is due to insufficient input sanitization and output escaping of uploaded image attachment titles. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially patched in 5.0.7.

NVD CVE-2026-2594Wordfence advisoryCode change (fix)

medium 4.3 CVE-2026-4066 · published 2026-03-23

Missing authorization check in Smart Custom Fields (5.0.6 and older)

Affected
5.0.6 and older
Fixed in
5.0.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smart Custom Fields plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the relational_posts_search() function in all versions up to, and including, 5.0.6. This makes it possible for authenticated attackers, with Contributor-level access and above, to read private and draft post content from other authors via the smart-cf-relational-posts-search AJAX action. The function queries posts with post_status=any and returns full WP_Post objects including post_content, but only checks the generic edit_posts capability instead of verifying whether the requesting user has permission to read each individual post.

NVD CVE-2026-4066Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-22308 · published 2025-01-07

Stored cross-site scripting (XSS) in Smart Custom Fields (5.0.0 and older)

Affected
5.0.0 and older
Fixed in
5.0.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Takashi Kitajima Smart Custom Fields smart-custom-fields allows Stored XSS.This issue affects Smart Custom Fields: from n/a through <= 5.0.0.

NVD CVE-2025-22308Patchstack advisory

medium 4.3 CVE-2024-1995 · published 2024-03-20

Missing authorization check in Smart Custom Fields (4.2.2 and older)

Affected
4.2.2 and older
Fixed in
5.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smart Custom Fields plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the relational_posts_search() function in all versions up to, and including, 4.2.2. This makes it possible for authenticated attackers, with subscrber-level access and above, to retrieve post content that is password protected and/or private.

NVD CVE-2024-1995Wordfence advisoryCode change (fix)github.comPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Smart Custom Fields vulnerability status badge
<a href="https://laskyr.com/plugins/smart-custom-fields"><img src="https://laskyr.com/plugins/smart-custom-fields/badge.svg" alt="Smart Custom Fields vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit