Skip to content
Laskyr

Plugins · smart-appointment-booking · data as of 2026-11-04

Is Smart Appointment & Booking safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.2)

As of 2026-11-04. 2 issues are on record for older versions; version 1.0.9 or newer fixes all of them that state a fix.

Latest version
2.0.2
Last updated
2026-06-05
Active installs
fewer than 10
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8

The Smart Appointment & Booking all-in-one plugin offers a seamless experience by providing customizable forms, email notifications, redirect users — by ZealousWeb

What to do

  1. Update to the latest version (2.0.2). Anything older than 1.0.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get smart-appointment-booking --field=version shows what you run; wp plugin update smart-appointment-booking updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-5693 · published 2026-05-12

Missing authorization check in Smart Appointment & Booking (1.0.8 and older)

Affected
1.0.8 and older
Fixed in
1.0.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smart Appointment & Booking plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check and a nonce validation logic flaw in the saab_cancel_booking() function in all versions up to, and including, 1.0.8. The nonce check uses && (AND) instead of || (OR), which means providing any value for the security parameter causes the entire check to be skipped. This makes it possible for unauthenticated attackers to cancel arbitrary bookings by supplying a predictable booking ID.

NVD CVE-2026-5693Wordfence advisorywordpress.orgPlugin source

medium 6.4 CVE-2026-0742 · published 2026-02-04

Stored cross-site scripting (XSS) in Smart Appointment & Booking (1.0.7 and older)

Affected
1.0.7 and older
Fixed in
1.0.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Smart Appointment & Booking plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the saab_save_form_data AJAX action in all versions up to, and including, 1.0.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-0742Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Smart Appointment & Booking vulnerability status badge
<a href="https://laskyr.com/plugins/smart-appointment-booking"><img src="https://laskyr.com/plugins/smart-appointment-booking/badge.svg" alt="Smart Appointment & Booking vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit