Plugins · slider-responsive-slideshow · data as of 2026-11-04
Is Responsive Slideshow safe? Known vulnerabilities and latest version
- Latest version
- 1.6.1
- Last updated
- 2026-10-05
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
Build responsive carousels with beautiful layout designs, swipe controls, and transitions for your website with Photo Carousel & Slider Plugin. — by A WP Life
What to do
- Update to the latest version (1.6.1). Anything older than 1.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get slider-responsive-slideshow --field=version shows what you run; wp plugin update slider-responsive-slideshow updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-22346 · published 2026-02-20
PHP object injection in Responsive Slideshow (1.5.4 and older)
- Affected
- 1.5.4 and older
- Fixed in
- 1.6.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in A WP Life Slider Responsive Slideshow – Image slider, Gallery slideshow slider-responsive-slideshow allows Object Injection.This issue affects Slider Responsive Slideshow – Image slider, Gallery slideshow: from n/a through <= 1.5.4.
high 8.8 CVE-2024-35722 · published 2024-06-10
Missing authorization check in Responsive Slideshow (1.4.0 and older)
- Affected
- 1.4.0 and older
- Fixed in
- 1.4.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Missing Authorization vulnerability in A WP Life Slider Responsive Slideshow – Image slider, Gallery slideshow.This issue affects Slider Responsive Slideshow – Image slider, Gallery slideshow: from n/a through 1.4.0.
high 8.8 CVE-2024-1859 · published 2024-03-01
PHP object injection in Responsive Slideshow (1.3.8 and older)
- Affected
- 1.3.8 and older
- Fixed in
- 1.4.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Slider Responsive Slideshow – Image slider, Gallery slideshow plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.3.8 via deserialization of untrusted input to the awl_slider_responsive_shortcode function. This makes it possible for authenticated attackers, with contributor-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Recent activity
- 2026-10-05 — latest release on wordpress.org (1.6.1).
- 2026-02-20 — PHP object injection disclosed (CVE-2026-22346), fixed in 1.6.0.
- 2024-06-10 — Missing authorization check disclosed (CVE-2024-35722), fixed in 1.4.2.
- 2024-03-01 — PHP object injection disclosed (CVE-2024-1859), fixed in 1.4.0.
Get an email when Responsive Slideshow has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Responsive Slideshow (slider-responsive-slideshow) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by A WP Life (8 tracked)
Types found in this plugin: PHP object injection (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/slider-responsive-slideshow (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/slider-responsive-slideshow"><img src="https://laskyr.com/plugins/slider-responsive-slideshow/badge.svg" alt="Responsive Slideshow vulnerability status"></a>