Skip to content
Laskyr

Plugins · slicewp · data as of 2026-11-04

Is Affiliate Program Suite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.14)

As of 2026-11-04. 8 issues are on record for older versions; version 1.2.14 or newer fixes all of them that state a fix.

Latest version
1.2.14
Last updated
2026-10-23
Active installs
10,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.3+

SliceWP is the powerful WordPress affiliate plugin that makes running your own affiliate program effortless. Track affiliate commissions, easily pay y … — by iova.mihai

What to do

  1. Update to the latest version (1.2.14). Anything older than 1.2.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get slicewp --field=version shows what you run; wp plugin update slicewp updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-115612 · published 2026-10-28

Stored cross-site scripting (XSS) in Affiliate Program Suite (1.2.13 and older)

Affected
1.2.13 and older
Fixed in
1.2.14
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in iova.mihai SliceWP slicewp allows Stored XSS.This issue affects SliceWP: from n/a through 1.2.13.

NVD CVE-2026-115612Patchstack advisory

high 7.1 CVE-2026-82224 · published 2026-08-31

Cross-site scripting (XSS) in Affiliate Program Suite (1.2.10 and older)

Affected
1.2.10 and older
Fixed in
1.2.11
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in SliceWP <= 1.2.10 versions.

NVD CVE-2026-82224Patchstack advisory

high 7.1 CVE-2026-42653 · published 2026-06-11

Stored cross-site scripting (XSS) in Affiliate Program Suite (1.2.6 and older)

Affected
1.2.6 and older
Fixed in
1.2.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in iova.Mihai SliceWP allows Stored XSS. This issue affects SliceWP: from n/a through 1.2.6.

NVD CVE-2026-42653Patchstack advisory

medium 6.4 CVE-2026-6672 · published 2026-05-06

Stored cross-site scripting (XSS) in Affiliate Program Suite (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.2.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Affiliate Program Suite — SliceWP Affiliates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via shortcode attributes in all versions up to, and including, 1.2.7. This is due to insufficient input sanitization and output escaping on user-supplied attributes in the 'slicewp_affiliate_url' shortcode. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-6672Wordfence advisoryCode change (fix)

medium 6.1 CVE-2024-12454 · published 2024-12-18

Cross-site request forgery (CSRF) in Affiliate Program Suite (1.1.23 and older)

Affected
1.1.23 and older
Fixed in
1.1.24 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Affiliate Program Suite — SliceWP Affiliates plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.1.23. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2024-12454Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 7.1 CVE-2024-47388 · published 2024-10-05

Reflected cross-site scripting (XSS) in Affiliate Program Suite (1.1.18 and older)

Affected
1.1.18 and older
Fixed in
1.1.19
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in iova.mihai SliceWP slicewp allows Reflected XSS.This issue affects SliceWP: from n/a through <= 1.1.18.

NVD CVE-2024-47388Patchstack advisory

medium 6.1 CVE-2024-8714 · published 2024-09-13

Reflected cross-site scripting (XSS) in Affiliate Program Suite (1.1.20 and older)

Affected
1.1.20 and older
Fixed in
1.1.21 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WordPress Affiliates Plugin — SliceWP Affiliates plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.1.20. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-8714Wordfence advisoryCode change (fix)Plugin source

medium 5.9 CVE-2024-34413 · published 2024-05-06

Stored cross-site scripting (XSS) in Affiliate Program Suite (1.1.10 and older)

Affected
1.1.10 and older
Fixed in
1.1.11
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SliceWP allows Stored XSS.This issue affects SliceWP: from n/a through 1.1.10.

NVD CVE-2024-34413Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Affiliate Program Suite vulnerability status badge
<a href="https://laskyr.com/plugins/slicewp"><img src="https://laskyr.com/plugins/slicewp/badge.svg" alt="Affiliate Program Suite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit