Skip to content
Laskyr

Plugins · skt-skill-bar · data as of 2026-11-04

Is SKT Skill Bar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1)

As of 2026-11-04. 5 issues are on record for older versions; version 2.6 or newer fixes all of them that state a fix.

Latest version
3.1
Last updated
2026-06-29
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Showcase skillsets that you are good at anywhere on your website using this plugin. — by Sonal S Sinha

What to do

  1. Update to the latest version (3.1). Anything older than 2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get skt-skill-bar --field=version shows what you run; wp plugin update skt-skill-bar updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-6972 · published 2026-08-05

Stored cross-site scripting (XSS) in SKT Skill Bar (2.6 and older)

Affected
2.6 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SKT Skill Bar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `chart_size` attribute of the `skillwrapper` shortcode in all versions up to, and including, 2.6. This is due to insufficient input sanitization and output escaping on the `chart_size` attribute, which is concatenated directly into an inline `<style>` block. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-6972Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-66090 · published 2025-11-21

Cross-site scripting (XSS) in SKT Skill Bar (2.5 and older)

Affected
2.5 and older
Fixed in
2.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in sonalsinha21 SKT Skill Bar skt-skill-bar allows DOM-Based XSS.This issue affects SKT Skill Bar: from n/a through <= 2.5.

NVD CVE-2025-66090Patchstack advisory

medium 6.5 CVE-2025-47482 · published 2025-05-07

Stored cross-site scripting (XSS) in SKT Skill Bar (2.4 and older)

Affected
2.4 and older
Fixed in
2.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in sonalsinha21 SKT Skill Bar skt-skill-bar allows Stored XSS.This issue affects SKT Skill Bar: from n/a through <= 2.4.

NVD CVE-2025-47482Patchstack advisory

medium 6.5 CVE-2025-26880 · published 2025-04-15

Stored cross-site scripting (XSS) in SKT Skill Bar (2.3 and older)

Affected
2.3 and older
Fixed in
2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in sonalsinha21 SKT Skill Bar skt-skill-bar allows Stored XSS.This issue affects SKT Skill Bar: from n/a through <= 2.3.

NVD CVE-2025-26880Patchstack advisory

medium 6.5 CVE-2024-38698 · published 2024-07-20

Stored cross-site scripting (XSS) in SKT Skill Bar (2.0 and older)

Affected
2.0 and older
Fixed in
2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in SKT Themes SKT Skill Bar allows Stored XSS.This issue affects SKT Skill Bar: from n/a through 2.0.

NVD CVE-2024-38698Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SKT Skill Bar vulnerability status badge
<a href="https://laskyr.com/plugins/skt-skill-bar"><img src="https://laskyr.com/plugins/skt-skill-bar/badge.svg" alt="SKT Skill Bar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit