Plugins · skt-builder · data as of 2026-11-04
Is SKT Page Builder safe? Known vulnerabilities and latest version
- Latest version
- 5.1
- Last updated
- 2026-10-13
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
SKT Page Builder has been designed and developed to assist anyone in creating pages using a drag and drop page builder interface. — by Sonal S Sinha
What to do
- Update to the latest version (5.1). Anything older than 5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get skt-builder --field=version shows what you run; wp plugin update skt-builder updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-54005 · published 2025-12-16
Missing authorization check in SKT Page Builder (4.9 and older)
- Affected
- 4.9 and older
- Fixed in
- 5.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in sonalsinha21 SKT Page Builder skt-builder allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects SKT Page Builder: from n/a through <= 4.9.
high 8.8 CVE-2024-12848 · published 2025-01-09
Arbitrary file upload in SKT Page Builder (4.7 and older)
- Affected
- 4.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SKT Page Builder plugin for WordPress is vulnerable to arbitrary file uploads due to a missing capability check on the 'addLibraryByArchive' function in all versions up to, and including, 4.6. This makes it possible for authenticated attackers, with subscriber-level access and above, to upload arbitrary files that make remote code execution possible.
NVD CVE-2024-12848Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2024-1337 · published 2024-02-29
Missing authorization check in SKT Page Builder (4.1 and older)
- Affected
- 4.1 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The SKT Page Builder plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'saveSktbuilderPageData' function in all versions up to, and including, 4.1. This makes it possible for authenticated attackers, with subscriber access and above, to inject arbitrary content into pages.
Recent activity
- 2026-10-13 — latest release on wordpress.org (5.1).
- 2025-12-16 — Missing authorization check disclosed (CVE-2025-54005), fixed in 5.0.
- 2025-01-09 — Arbitrary file upload disclosed (CVE-2024-12848), fix version not stated.
- 2024-02-29 — Missing authorization check disclosed (CVE-2024-1337), fix version not stated.
Get an email when SKT Page Builder has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for SKT Page Builder (skt-builder) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Sonal S Sinha (4 tracked)
Types found in this plugin: Missing authorization (2) · Arbitrary file upload (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/skt-builder (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/skt-builder"><img src="https://laskyr.com/plugins/skt-builder/badge.svg" alt="SKT Page Builder vulnerability status"></a>