Skip to content
Laskyr

Plugins · skt-addons-for-elementor · data as of 2026-11-04

Is SKT Addons for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.2)

As of 2026-11-04. 8 issues are on record for older versions; version 4.1 or newer fixes all of them that state a fix.

Latest version
4.2
Last updated
2026-10-27
Active installs
1,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

SKT Addons for Elementor is one of the great Elementor Addons which comes With 123 completely Free Elementor Widgets including Business hour, image gr … — by Sonal S Sinha

What to do

  1. Update to the latest version (4.2). Anything older than 4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get skt-addons-for-elementor --field=version shows what you run; wp plugin update skt-addons-for-elementor updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.6 CVE-2026-66626 · published 2026-09-17

SQL injection in SKT Addons for Elementor (4.0 and older)

Affected
4.0 and older
Fixed in
4.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Editor SQL Injection in SKT Addons for Elementor <= 4.0 versions.

NVD CVE-2026-66626Patchstack advisory

medium 6.4 CVE-2025-8564 · published 2025-09-06

Stored cross-site scripting (XSS) in SKT Addons for Elementor (3.7 and older)

Affected
3.7 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SKT Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple widgets in all versions up to, and including, 3.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-8564Wordfence advisoryCode change (fix)wordpress.org

medium 6.5 CVE-2025-30812 · published 2025-03-27

Stored cross-site scripting (XSS) in SKT Addons for Elementor (3.5 and older)

Affected
3.5 and older
Fixed in
3.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in sonalsinha21 SKT Addons for Elementor skt-addons-for-elementor allows Stored XSS.This issue affects SKT Addons for Elementor: from n/a through <= 3.5.

NVD CVE-2025-30812Patchstack advisory

medium 4.3 CVE-2024-10693 · published 2024-11-09

Information disclosure in SKT Addons for Elementor (3.3 and older)

Affected
3.3 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SKT Addons for Elementor plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 3.3 via the Unfold widget due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private or draft posts created by Elementor that they should not have access to.

NVD CVE-2024-10693Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-38674 · published 2024-07-20

Stored cross-site scripting (XSS) in SKT Addons for Elementor (3.0 and older)

Affected
3.0 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in SKT Themes SKT Addons for Elementor allows Stored XSS.This issue affects SKT Addons for Elementor: from n/a through 3.0.

NVD CVE-2024-38674Patchstack advisory

medium 5.4 CVE-2024-5091 · published 2024-06-08

Stored cross-site scripting (XSS) in SKT Addons for Elementor (2.0 and older)

Affected
2.0 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The SKT Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Age Gate and Creative Slider widgets in all versions up to, and including, 2.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5091Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-34445 · published 2024-05-14

Stored cross-site scripting (XSS) in SKT Addons for Elementor (1.8 and older)

Affected
1.8 and older
Fixed in
1.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SKT Themes SKT Addons for Elementor allows Stored XSS.This issue affects SKT Addons for Elementor: from n/a through 1.8.

NVD CVE-2024-34445Patchstack advisory

medium 5.4 CVE-2024-34436 · published 2024-05-14

Stored cross-site scripting (XSS) in SKT Addons for Elementor (1.8 and older)

Affected
1.8 and older
Fixed in
1.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SKT Themes SKT Addons for Elementor allows Stored XSS.This issue affects SKT Addons for Elementor: from n/a through 1.8.

NVD CVE-2024-34436Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SKT Addons for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/skt-addons-for-elementor"><img src="https://laskyr.com/plugins/skt-addons-for-elementor/badge.svg" alt="SKT Addons for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit