Plugins · sitewide-notice-wp · data as of 2026-11-04
Is Sitewide Notice WP safe? Known vulnerabilities and latest version
- Latest version
- 2.4.2
- Last updated
- 2025-12-03
- Active installs
- 3,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Simply add a small message bar to the bottom of each page of your website to display notice messages such as sales, notices and any text messages. — by Andrew Lima
What to do
- Update to the latest version (2.4.2). Anything older than 2.4.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get sitewide-notice-wp --field=version shows what you run; wp plugin update sitewide-notice-wp updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-67575 · published 2025-12-09
Missing authorization check in Sitewide Notice WP (2.4.1 and older)
- Affected
- 2.4.1 and older
- Fixed in
- 2.4.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Andrew Lima Sitewide Notice WP sitewide-notice-wp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Sitewide Notice WP: from n/a through <= 2.4.1.
medium 4.8 CVE-2021-24592 · published 2021-08-30
Cross-site scripting (XSS) in Sitewide Notice WP (older than 2.3)
- Affected
- older than 2.3
- Fixed in
- 2.3
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Sitewide Notice WP WordPress plugin before 2.3 does not sanitise some of its settings before outputting them in frontend pages, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Recent activity
- 2025-12-03 — latest release on wordpress.org (2.4.2).
- 2025-12-09 — Missing authorization check disclosed (CVE-2025-67575), fixed in 2.4.2.
- 2021-08-30 — Cross-site scripting (XSS) disclosed (CVE-2021-24592), fixed in 2.3.
Get an email when Sitewide Notice WP has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Sitewide Notice WP (sitewide-notice-wp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/sitewide-notice-wp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/sitewide-notice-wp"><img src="https://laskyr.com/plugins/sitewide-notice-wp/badge.svg" alt="Sitewide Notice WP vulnerability status"></a>