Skip to content
Laskyr

Plugins · siteseo · data as of 2026-11-01

Is SiteSEO safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.2)

As of 2026-11-01. 4 issues are on record for older versions; version 1.3.3 or newer fixes all of them that state a fix.

Latest version
1.4.2
Last updated
2026-09-24
Active installs
400,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

SiteSEO is an easy, fast and powerful SEO plugin for WordPress. Unlock your Website's potential and Maximize your online visibility with our SiteSEO! — by Softaculous

What to do

  1. Update to the latest version (1.4.2). Anything older than 1.3.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get siteseo --field=version shows what you run; wp plugin update siteseo updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-13085 · published 2025-11-19

Missing authorization check in SiteSEO (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SiteSEO – SEO Simplified plugin for WordPress is vulnerable to Improper Authorization leading to Sensitive Post Meta Disclosure in versions up to and including 1.3.2. This is due to missing object-level authorization checks in the resolve_variables() AJAX handler. This makes it possible for authenticated attackers with the siteseo_manage capability (e.g., Author-level users who have been granted SiteSEO access by an administrator) to read arbitrary post metadata from any post, page, attachment, or WooCommerce order they cannot edit, via the custom field variable resolution feature granted they have been given access to SiteSEO by an administrator and legacy storage is enabled. In affected WooCommerce installations, this exposes sensitive customer billing information including names, email addresses, phone numbers, physical addresses, and payment methods.

NVD CVE-2025-13085Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-12814 · published 2025-11-19

Missing authorization check in SiteSEO (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SiteSEO – SEO Simplified plugin for WordPress is vulnerable to unauthorized modification of data due to n incorrect capability check on the siteseo_reset_settings function in all versions up to, and including, 1.3.2. This makes it possible for authenticated attackers, who have been granted access to at least on SiteSEO setting capability, to reset the plugin's settings.

NVD CVE-2025-12814Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2025-12367 · published 2025-11-01

Missing authorization check in SiteSEO (1.3.1 and older)

Affected
1.3.1 and older
Fixed in
1.3.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SiteSEO – SEO Simplified plugin for WordPress is vulnerable to Missing Authorization in versions up to, and including, 1.3.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with Author-level access and above, to enable or disable arbitrary SiteSEO features that they should not have access to.

NVD CVE-2025-12367Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-9277 · published 2025-08-26

Stored cross-site scripting (XSS) in SiteSEO (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.2.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SiteSEO – SEO Simplified plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the broken preg_replace expression in all versions up to, and including, 1.2.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-9277Wordfence advisoryPlugin source

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SiteSEO vulnerability status badge
<a href="https://laskyr.com/plugins/siteseo"><img src="https://laskyr.com/plugins/siteseo/badge.svg" alt="SiteSEO vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit