Skip to content
Laskyr

Plugins · siteguard · data as of 2026-11-01

Is SiteGuard WP Plugin safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.8.10)

As of 2026-11-01. 2 issues are on record for older versions; version 1.8.7 or newer fixes all of them that state a fix.

Latest version
1.8.10
Last updated
2026-10-27
Active installs
600,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Adds WordPress login and admin protections, including CAPTCHA, login lock, login alerts, renamed login URLs, and SiteGuard WAF tuning support. — by jp-secure

What to do

  1. Update to the latest version (1.8.10). Anything older than 1.8.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get siteguard --field=version shows what you run; wp plugin update siteguard updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-61982 · published 2026-08-06

Cross-site scripting (XSS) in SiteGuard WP Plugin (1.8.6 and older)

Affected
1.8.6 and older
Fixed in
1.8.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in SiteGuard WP Plugin <= 1.8.6 versions.

NVD CVE-2026-61982Patchstack advisory

medium 5.4 CVE-2026-27411 · published 2026-03-05

Security issue in SiteGuard WP Plugin (1.7.9 and older)

Affected
1.7.9 and older
Fixed in
1.7.10
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Guessable CAPTCHA vulnerability in jp-secure SiteGuard WP Plugin siteguard allows Functionality Bypass.This issue affects SiteGuard WP Plugin: from n/a through <= 1.7.9.

NVD CVE-2026-27411Patchstack advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SiteGuard WP Plugin vulnerability status badge
<a href="https://laskyr.com/plugins/siteguard"><img src="https://laskyr.com/plugins/siteguard/badge.svg" alt="SiteGuard WP Plugin vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit