Skip to content
Laskyr

Plugins · simply-rets · data as of 2026-11-04

Is SimplyRETS Real Estate IDX safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.0)

As of 2026-11-04. 5 issues are on record for older versions; version 3.3.0 or newer fixes all of them that state a fix.

Latest version
3.3.0
Last updated
2026-10-11
Active installs
200+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8

Show your MLS listings on your website, simply! We make it easy add your listings to your website with full control. Contact us to get started today. — by ReichertBrothers

What to do

  1. Update to the latest version (3.3.0). Anything older than 3.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simply-rets --field=version shows what you run; wp plugin update simply-rets updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-105066 · published 2026-10-14

Reflected cross-site scripting (XSS) in SimplyRETS Real Estate IDX (3.2.9 and older)

Affected
3.2.9 and older
Fixed in
3.3.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in SimplyRETS SimplyRETS Real Estate IDX simply-rets allows Reflected XSS.This issue affects SimplyRETS Real Estate IDX: from n/a through 3.2.9.

NVD CVE-2026-105066Patchstack advisory

high 7.1 CVE-2026-73354 · published 2026-08-19

Cross-site scripting (XSS) in SimplyRETS Real Estate IDX (3.2.8 and older)

Affected
3.2.8 and older
Fixed in
3.2.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in SimplyRETS Real Estate IDX <= 3.2.8 versions.

NVD CVE-2026-73354Patchstack advisory

high 7.1 CVE-2025-31011 · published 2025-04-15

Reflected cross-site scripting (XSS) in SimplyRETS Real Estate IDX (3.2.2 and older)

Affected
3.2.2 and older
Fixed in
3.2.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ReichertBrothers SimplyRETS Real Estate IDX simply-rets allows Reflected XSS.This issue affects SimplyRETS Real Estate IDX: from n/a through <= 3.2.2.

NVD CVE-2025-31011Patchstack advisory

medium 4.3 CVE-2025-31010 · published 2025-03-28

Cross-site request forgery (CSRF) in SimplyRETS Real Estate IDX (3.0.5 and older)

Affected
3.0.5 and older
Fixed in
3.1.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in ReichertBrothers SimplyRETS Real Estate IDX simply-rets allows Cross Site Request Forgery.This issue affects SimplyRETS Real Estate IDX: from n/a through <= 3.0.5.

NVD CVE-2025-31010Patchstack advisory

medium 6.4 CVE-2024-12491 · published 2025-01-09

Stored cross-site scripting (XSS) in SimplyRETS Real Estate IDX (2.11.3 and older)

Affected
2.11.3 and older
Fixed in
3.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SimplyRETS Real Estate IDX plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'sr_search_form' shortcode in all versions up to, and including, 2.11.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-12491Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SimplyRETS Real Estate IDX vulnerability status badge
<a href="https://laskyr.com/plugins/simply-rets"><img src="https://laskyr.com/plugins/simply-rets/badge.svg" alt="SimplyRETS Real Estate IDX vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit