Skip to content
Laskyr

Plugins · simply-gallery-block · data as of 2026-11-04

Is SimpLy Gallery safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.5)

As of 2026-11-04. 7 issues are on record for older versions; version 3.3.3.2 or newer fixes all of them that state a fix.

Latest version
3.4.5
Last updated
2026-10-12
Active installs
40,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Create photo and video galleries with albums, sliders and a lightbox. Includes free Media Library folders to organize your files. — by GalleryCreator

What to do

  1. Update to the latest version (3.4.5). Anything older than 3.3.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simply-gallery-block --field=version shows what you run; wp plugin update simply-gallery-block updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-5743 · published 2026-07-11

Stored cross-site scripting (XSS) in SimpLy Gallery (3.3.3.1 and older)

Affected
3.3.3.1 and older
Fixed in
3.3.3.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SimpLy Gallery Block & Lightbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via block attributes in all versions up to, and including, 3.3.3.2. This is due to insufficient input sanitization and output escaping on the sliderMaxHeight block attribute in the pgc_sgb_render_callback() function. The vulnerability exists because the pgc_sgb_sanitize_custom_css() function uses a flawed regex pattern that only removes event handlers with quoted values (e.g., onfocus="alert()") but fails to catch unquoted event handlers (e.g., onfocus=alert(document.cookie)), allowing the malicious code to bypass sanitization. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages via block attributes that will execute whenever a user accesses an injected page.

NVD CVE-2026-5743Wordfence advisoryCode change (fix)Plugin source

critical 9.9 CVE-2026-25345 · published 2026-03-25

Security issue in SimpLy Gallery (3.3.2 and older)

Affected
3.3.2 and older
Fixed in
3.3.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Validation of Specified Quantity in Input vulnerability in GalleryCreator SimpLy Gallery simply-gallery-block allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects SimpLy Gallery: from n/a through <= 3.3.2.

NVD CVE-2026-25345Patchstack advisory

medium 4.3 CVE-2025-14288 · published 2025-12-13

Missing authorization check in SimpLy Gallery (3.3.0 and older)

Affected
3.3.0 and older
Fixed in
3.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gallery Blocks with Lightbox. Image Gallery, (HTML5 video , YouTube, Vimeo) Video Gallery and Lightbox for native gallery plugin for WordPress is vulnerable to unauthorized modification of plugin settings in all versions up to, and including, 3.3.0. This is due to the plugin using the `edit_posts` capability check instead of `manage_options` for the `update_option` action type in the `pgc_sgb_action_wizard` AJAX handler. This makes it possible for authenticated attackers, with Contributor-level access and above, to modify arbitrary plugin settings prefixed with `pgc_sgb_*`.

NVD CVE-2025-14288Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-63052 · published 2025-12-09

Stored cross-site scripting (XSS) in SimpLy Gallery (3.3.2.1 and older)

Affected
3.3.2.1 and older
Fixed in
3.3.2.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GalleryCreator SimpLy Gallery simply-gallery-block allows Stored XSS.This issue affects SimpLy Gallery: from n/a through <= 3.3.2.1.

NVD CVE-2025-63052Patchstack advisory

medium 6.5 CVE-2025-32176 · published 2025-04-04

Stored cross-site scripting (XSS) in SimpLy Gallery (3.2.5 and older)

Affected
3.2.5 and older
Fixed in
3.2.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GalleryCreator SimpLy Gallery simply-gallery-block allows Stored XSS.This issue affects SimpLy Gallery: from n/a through <= 3.2.5.

NVD CVE-2025-32176Patchstack advisory

medium 5.5 CVE-2024-10034 · published 2024-11-22

Stored cross-site scripting (XSS) in SimpLy Gallery (3.2.4.2 and older)

Affected
3.2.4.2 and older
Fixed in
3.2.4.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gallery Blocks with Lightbox. Image Gallery, (HTML5 video , YouTube, Vimeo) Video Gallery and Lightbox for native gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the gallery link text parameter in all versions up to, and including, 3.2.4.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Editor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-10034Wordfence advisoryCode change (fix)

medium 6.4 CVE-2024-5424 · published 2024-06-28

Stored cross-site scripting (XSS) in SimpLy Gallery (3.2.1 and older)

Affected
3.2.1 and older
Fixed in
3.2.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Gallery Blocks with Lightbox. Image Gallery, (HTML5 video , YouTube, Vimeo) Video Gallery and Lightbox for native gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘galleryID’ and 'className' parameters in all versions up to, and including, 3.2.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5424Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
SimpLy Gallery vulnerability status badge
<a href="https://laskyr.com/plugins/simply-gallery-block"><img src="https://laskyr.com/plugins/simply-gallery-block/badge.svg" alt="SimpLy Gallery vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit