Skip to content
Laskyr

Plugins · simple-yearly-archive · data as of 2026-11-04

Is Simple Yearly Archive safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.8)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2.5 or newer fixes all of them that state a fix.

Latest version
2.2.8
Last updated
2026-11-03
Active installs
6,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Simple Yearly Archive is a rather neat and simple Wordpress plugin that allows you to display your archives in a year-based list. — by wpseek

What to do

  1. Update to the latest version (2.2.8). Anything older than 2.2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simple-yearly-archive --field=version shows what you run; wp plugin update simple-yearly-archive updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-7441 · published 2026-08-05

Stored cross-site scripting (XSS) in Simple Yearly Archive (2.2.4 and older)

Affected
2.2.4 and older
Fixed in
2.2.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Simple Yearly Archive plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `posttype` attribute of the `SimpleYearlyArchive` shortcode in all versions up to, and including, 2.2.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-7441Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 4.8 CVE-2023-25484 · published 2023-04-25

Stored cross-site scripting (XSS) in Simple Yearly Archive (2.1.8 and older)

Affected
2.1.8 and older
Fixed in
2.1.9
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Oliver Schlöbe Simple Yearly Archive plugin <= 2.1.8 versions.

NVD CVE-2023-25484Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Yearly Archive vulnerability status badge
<a href="https://laskyr.com/plugins/simple-yearly-archive"><img src="https://laskyr.com/plugins/simple-yearly-archive/badge.svg" alt="Simple Yearly Archive vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit