Plugins · simple-social-buttons · data as of 2026-11-04
Is Simple Social Media Share Buttons safe? Known vulnerabilities and latest version
- Latest version
- 7.2.0
- Last updated
- 2026-10-19
- Active installs
- 20,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.1+
This Social Share Plugin adds advanced social media sharing buttons to your WordPress sites, such as Facebook, WhatsApp, X, LinkedIn, & Pinterest. — by Adnan
What to do
- Update to the latest version (7.2.0). Anything older than 6.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-social-buttons --field=version shows what you run; wp plugin update simple-social-buttons updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-34904 · published 2026-04-07
Cross-site request forgery (CSRF) in Simple Social Media Share Buttons (6.2.0 and older)
- Affected
- 6.2.0 and older
- Fixed in
- 6.2.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Analytify Simple Social Media Share Buttons allows Cross Site Request Forgery.This issue affects Simple Social Media Share Buttons: from n/a through 6.2.0.
medium 4.8 CVE-2024-13610 · published 2025-04-15
Stored cross-site scripting (XSS) in Simple Social Media Share Buttons (older than 6.0.0)
- Affected
- older than 6.0.0
- Fixed in
- 6.0.0
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Simple Social Media Share Buttons WordPress plugin before 6.0.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
medium 5.3 CVE-2023-5845 · published 2023-11-27
Security issue in Simple Social Media Share Buttons (older than 5.1.1)
- Affected
- older than 5.1.1
- Fixed in
- 5.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Simple Social Media Share Buttons WordPress plugin before 5.1.1 leaks password-protected post content to unauthenticated visitors in some meta tags
medium 4.8 CVE-2021-24656 · published 2021-10-11
Cross-site scripting (XSS) in Simple Social Media Share Buttons (older than 3.2.4)
- Affected
- older than 3.2.4
- Fixed in
- 3.2.4
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Simple Social Media Share Buttons WordPress plugin before 3.2.4 does not escape the Share Title settings before outputting it in the frontend pages or posts (depending on the settings used), allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
medium 5.4 CVE-2021-24486 · published 2021-08-23
Stored cross-site scripting (XSS) in Simple Social Media Share Buttons (older than 3.2.3)
- Affected
- older than 3.2.3
- Fixed in
- 3.2.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Simple Social Media Share Buttons – Social Sharing for Everyone WordPress plugin before 3.2.3 did not escape the align and like_button_size parameters of its SSB shortcode, which could allow users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks.
Recent activity
- 2026-10-19 — latest release on wordpress.org (7.2.0).
- 2026-04-07 — Cross-site request forgery (CSRF) disclosed (CVE-2026-34904), fixed in 6.2.1.
- 2025-04-15 — Stored cross-site scripting (XSS) disclosed (CVE-2024-13610), fixed in 6.0.0.
- 2023-11-27 — Security issue disclosed (CVE-2023-5845), fixed in 5.1.1.
Get an email when Simple Social Media Share Buttons has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple Social Media Share Buttons (simple-social-buttons) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-social-buttons (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-social-buttons"><img src="https://laskyr.com/plugins/simple-social-buttons/badge.svg" alt="Simple Social Media Share Buttons vulnerability status"></a>