Plugins · simple-retail-menus · data as of 2026-11-04
Is Simple Retail Menus safe? Known vulnerabilities and latest version
- Latest version
- 4.2.1
- Last updated
- 2014-03-15
- Active installs
- 90+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 3.7.41
Create and manage restaurant, salon, and retail store menu lists of services, food items, retail items, or other data. — by whatwouldjessedo
What to do
- There is no fixed version yet. If you can live without Simple Retail Menus for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get simple-retail-menus --field=version shows what you run; wp plugin update simple-retail-menus updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 affects latest 4.2.1 CVE-2025-69387 · published 2026-02-20
File inclusion in Simple Retail Menus (4.2.1 and older)
- Affected
- 4.2.1 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in whatwouldjessedo Simple Retail Menus simple-retail-menus allows PHP Local File Inclusion.This issue affects Simple Retail Menus: from n/a through <= 4.2.1.
medium 6.5 CVE-2014-5183 · published 2014-08-06
SQL injection in Simple Retail Menus (4.0.1 and older, 4.0 only)
- Affected
- 4.0.1 and older, 4.0 only
- Fixed in
- 4.1 *
- Range from
- NVD analysis · score by NVD
Details from the advisory
SQL injection vulnerability in includes/mode-edit.php in the Simple Retail Menus (simple-retail-menus) plugin before 4.1 for WordPress allows remote authenticated editors to execute arbitrary SQL commands via the targetmenu parameter in an edit action to wp-admin/admin.php.
Recent activity
- 2014-03-15 — latest release on wordpress.org (4.2.1).
- 2026-02-20 — File inclusion disclosed (CVE-2025-69387), no fix listed yet.
- 2014-08-06 — SQL injection disclosed (CVE-2014-5183), fixed in 4.1.
Get an email when Simple Retail Menus has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple Retail Menus (simple-retail-menus) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: File inclusion (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-retail-menus (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-retail-menus"><img src="https://laskyr.com/plugins/simple-retail-menus/badge.svg" alt="Simple Retail Menus vulnerability status"></a>