Plugins · simple-payment · data as of 2026-11-04
Is Simple Payment safe? Known vulnerabilities and latest version
- Latest version
- 2.5.23
- Last updated
- 2026-10-26
- Active installs
- 40+
- Known issues on record
- 8
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Turn any post, page or form into a "Buy Now" — collect credit-card payments, donations and recurring charges through the gateway you already … — by Ido Kobelkowsky
What to do
- Update to the latest version (2.5.23). Anything older than 2.5.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-payment --field=version shows what you run; wp plugin update simple-payment updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-96332 · published 2026-10-09
Reflected cross-site scripting (XSS) in Simple Payment (2.5.4 and older)
- Affected
- 2.5.4 and older
- Fixed in
- 2.5.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in yalla ya! Simple Payment simple-payment allows Reflected XSS.This issue affects Simple Payment: from n/a through 2.5.4.
medium 6.5 CVE-2026-62111 · published 2026-09-11
Cross-site scripting (XSS) in Simple Payment (2.5.4 and older)
- Affected
- 2.5.4 and older
- Fixed in
- 2.5.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Cross Site Scripting (XSS) in Simple Payment <= 2.5.4 versions.
high 7.1 CVE-2026-81292 · published 2026-09-03
Cross-site scripting (XSS) in Simple Payment (2.5.1 and older)
- Affected
- 2.5.1 and older
- Fixed in
- 2.5.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Simple Payment <= 2.5.1 versions.
high 7.5 CVE-2026-81767 · published 2026-08-28
Missing authorization check in Simple Payment (2.5.2 and older)
- Affected
- 2.5.2 and older
- Fixed in
- 2.5.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Simple Payment <= 2.5.2 versions.
high 7.5 CVE-2025-62075 · published 2025-11-06
File inclusion in Simple Payment (2.4.6 and older)
- Affected
- 2.4.6 and older
- Fixed in
- 2.4.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Ido Kobelkowsky Simple Payment simple-payment.This issue affects Simple Payment: from n/a through <= 2.4.6.
high 7.1 CVE-2025-62076 · published 2025-11-06
Cross-site scripting (XSS) in Simple Payment (2.4.6 and older)
- Affected
- 2.4.6 and older
- Fixed in
- 2.4.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ido Kobelkowsky Simple Payment simple-payment.This issue affects Simple Payment: from n/a through <= 2.4.6.
critical 9.8 CVE-2025-6688 · published 2025-06-27
Authentication bypass in Simple Payment (1.3.6 to 2.3.8)
- Affected
- 1.3.6 to 2.3.8
- Fixed in
- 2.3.9 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple Payment plugin for WordPress is vulnerable to Authentication Bypass in versions 1.3.6 to 2.3.8. This is due to the plugin not properly verifying a user's identity prior to logging them in through the create_user() function. This makes it possible for unauthenticated attackers to log in as administrative users.
high 7.1 CVE-2024-54303 · published 2024-12-13
Reflected cross-site scripting (XSS) in Simple Payment (2.3.8 and older)
- Affected
- 2.3.8 and older
- Fixed in
- 2.3.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ido Kobelkowsky Simple Payment simple-payment allows Reflected XSS.This issue affects Simple Payment: from n/a through <= 2.3.8.
Recent activity
- 2026-10-26 — latest release on wordpress.org (2.5.23).
- 2026-10-09 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-96332), fixed in 2.5.6.
- 2026-09-11 — Cross-site scripting (XSS) disclosed (CVE-2026-62111), fixed in 2.5.6.
- 2026-09-03 — Cross-site scripting (XSS) disclosed (CVE-2026-81292), fixed in 2.5.2.
Get an email when Simple Payment has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple Payment (simple-payment) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (5) · Missing authorization (1) · File inclusion (1) · Authentication bypass (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-payment (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-payment"><img src="https://laskyr.com/plugins/simple-payment/badge.svg" alt="Simple Payment vulnerability status"></a>