Skip to content
Laskyr

Plugins · simple-membership-wp-user-import · data as of 2026-11-04

Is Simple Membership WP user Import safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.2)

As of 2026-11-04. 2 issues are on record for older versions; version 1.9.2 or newer fixes all of them that state a fix.

Latest version
1.9.2
Last updated
2026-08-21
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

An addon for importing existing WordPress users to the Simple Membership plugin as members — by wp.insider

What to do

  1. Update to the latest version (1.9.2). Anything older than 1.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get simple-membership-wp-user-import --field=version shows what you run; wp plugin update simple-membership-wp-user-import updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-24986 · published 2026-02-03

Cross-site request forgery (CSRF) in Simple Membership WP user Import (1.9.1 and older)

Affected
1.9.1 and older
Fixed in
1.9.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in wp.insider Simple Membership WP user Import simple-membership-wp-user-import allows Cross Site Request Forgery.This issue affects Simple Membership WP user Import: from n/a through <= 1.9.1.

NVD CVE-2026-24986Patchstack advisory

medium 4.9 CVE-2023-0254 · published 2023-01-12

SQL injection in Simple Membership WP user Import (1.7 and older)

Affected
1.7 and older
Fixed in
1.9.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Simple Membership WP user Import plugin for WordPress is vulnerable to SQL Injection via the ‘orderby’ parameter in versions up to, and including, 1.7 due to insufficient escaping on the user supplied parameter. This makes it possible for authenticated attackers with administrative privileges to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2023-0254Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Simple Membership WP user Import vulnerability status badge
<a href="https://laskyr.com/plugins/simple-membership-wp-user-import"><img src="https://laskyr.com/plugins/simple-membership-wp-user-import/badge.svg" alt="Simple Membership WP user Import vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit