Plugins · simple-history · data as of 2026-11-01
Is Simple History safe? Known vulnerabilities and latest version
- Latest version
- 5.36.0
- Last updated
- 2026-10-17
- Active installs
- 300,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Track changes and user activities on your WordPress site. See who created a page, uploaded an attachment, and more, for a complete audit trail. — by Pär Thernström
What to do
- Update to the latest version (5.36.0). Anything older than 5.27.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get simple-history --field=version shows what you run; wp plugin update simple-history updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-7459 · published 2026-05-30
Weak password recovery in Simple History (5.26.0 and older)
- Affected
- 5.26.0 and older
- Fixed in
- 5.27.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple History – Track, Log, and Audit WordPress Changes plugin for WordPress is vulnerable to authenticated (Subscriber+) account takeover in all versions up to, and including, 5.26.0 via the event reaction endpoints (react_to_event() / unreact_to_event()). The endpoints register get_items_permissions_check() as their permission_callback, which only verifies the requester is logged in and does not enforce the per-logger capability checks normally applied by Log_Query. As a result, a Subscriber-level user can POST to /wp-json/simple-history/v1/events/<id>/react with the _fields=context query parameter and read the full context of any Simple History event — including SimpleUserLogger entries that record the full password-reset email body (reset URL with the reset key) for any user. The attacker triggers a password reset for an administrator via the lost-password form, brute-forces recent event IDs through the reaction endpoint to read the resulting user_requested_password_reset_link event, extracts the reset key from context.message, and completes the password reset to take over the administrator account. Exploitation requires an administrator to have first enabled the experimental features option (simple_history_experimental_features_enabled), which is not the default.
NVD CVE-2026-7459Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2026-39473 · published 2026-04-08
Information disclosure in Simple History (5.24.0 and older)
- Affected
- 5.24.0 and older
- Fixed in
- 5.24.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in Pär Thernström Simple History simple-history allows Retrieve Embedded Sensitive Data.This issue affects Simple History: from n/a through <= 5.24.0.
medium 4.9 CVE-2025-5760 · published 2025-06-06
Information disclosure in Simple History (5.8.1 and older)
- Affected
- 5.8.1 and older
- Fixed in
- 5.8.2 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Simple History plugin for WordPress is vulnerable to sensitive data exposure via Detective Mode due to improper sanitization within the append_debug_info_to_context() function in versions prior to 5.8.1. When Detective Mode is enabled, the plugin’s logger captures the entire contents of $_POST (and sometimes raw request bodies or $_GET) without redacting any password‐related keys. As a result, whenever a user submits a login form, whether via native wp_login or a third‐party login widget, their actual password is written in clear text into the logs. An authenticated attacker or any user whose actions generate a login event will have their password recorded; an administrator (or anyone with database read access) can then read those logs and retrieve every captured password.
NVD CVE-2025-5760Wordfence advisoryCode change (fix)wordpress.orggithub.comgithub.comsimple-history.com
high 8.8 CVE-2022-45350 · published 2023-11-07
CSV injection in Simple History (3.3.1 and older)
- Affected
- 3.3.1 and older
- Fixed in
- 3.4.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Formula Elements in a CSV File vulnerability in Pär Thernström Simple History – user activity log, audit tool.This issue affects Simple History – user activity log, audit tool: from n/a through 3.3.1.
Recent activity
- 2026-10-17 — latest release on wordpress.org (5.36.0).
- 2026-05-30 — Weak password recovery disclosed (CVE-2026-7459), fixed in 5.27.0.
- 2026-04-08 — Information disclosure disclosed (CVE-2026-39473), fixed in 5.24.1.
- 2025-06-06 — Information disclosure disclosed (CVE-2025-5760), fixed in 5.8.2.
Get an email when Simple History has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Simple History (simple-history) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/simple-history (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/simple-history"><img src="https://laskyr.com/plugins/simple-history/badge.svg" alt="Simple History vulnerability status"></a>